Linked Questions

191
votes
2answers
416k views

How to install specific version of some package? [duplicate]

My questions are divided into two parts: How to know the version of installed package? How to install a specific package version?
5
votes
1answer
24k views

how to install a specific package version [duplicate]

I'm building my first debian package (django), which needs some dependencies, so I was wondering if it's possible to install a specific package version with apt-get. For example instead of pip ...
1
vote
1answer
3k views

Install Specific Version of Ruby with `apt-get install ruby-full ruby-dev` [duplicate]

When I execute apt-get install ruby-full ruby-dev I am getting ruby 2.3. I want ruby 1.9.3. How do I get it to install ruby 1.9.3? I'm using Ubuntu 16.0.4 Xenial.
1
vote
1answer
2k views

How can I switch between versions of an installed package with apt-get? [duplicate]

On 12.04, I have the latest version of Ocaml (4.01) installed with all the dependencies. I'm trying to install Coq, which depends on an older version (3.12) of the ocaml-base-nox runtime (via a ...
0
votes
1answer
412 views

How to stop Postgres from auto update on Ubuntu? [duplicate]

I was using Postgres 9.5.6 for my personal project and today when I logged in to Postgres, the version was 9.5.8 which also caused an auto restart. I would like to know how to stop a package (...
0
votes
2answers
190 views

How to download a specific version of Duplicity [duplicate]

How do I install a specific version of duplicity. The one I have is duplicity 0.6.21 and the one I want is 0.6.18
0
votes
0answers
18 views

Reinstall package keeping current wersion [duplicate]

As documentation says: apt-get install --reinstall reinstalls packages at the newest version. How do I reinstall the same version of the package as one currently in the system?
15
votes
4answers
102k views

How to install previous Firefox version?

I'm using Ubuntu 14.04 and I use the Perapera Chinese add-on for Firefox. It worked up to version 39, but now in version 40 it just stopped working. So I tried to downgrade to version 39 following ...
5
votes
4answers
26k views

Install Apache 2.2.22 on Ubuntu 14.04

There are a ton of resources to which none of them are useful on how to install Apache 2.2 from Precise (12.04) on ubuntu trusty (14.04). Can someone please help with a detailed answer of how to ...
0
votes
2answers
13k views

How to install gcc 4.1.2 on Ubuntu 16.04 ?

How can I install the old version of gcc (gcc-4.1.2) on Ubuntu? ( without Synaptic ) .My actual version of gcc is gcc-4.4.7
2
votes
4answers
3k views

How do I fetch a specific package version from a repository?

Adding a PPA then running apt-get update to fetch seems to only fetch the latest version from that PPA, but I would like to install a specific version. Eg: I'm adding the ondrej/php5-5.6 ppa. After ...
5
votes
3answers
4k views

How to downgrade from LibreOffice 4.0 to 3.6?

How to "properly" downgrade LibreOffice versions deals with a downgrade from 3.5 to 3.4.*. Is there any way to nicely downgrade LibreOffice 4.0 to 3.6? The latter is not in the package lists....
1
vote
1answer
5k views

Can't install mesa-common-dev

I can't install this package, it gives me an error, this is the output from terminal: ➜ ~ sudo apt-get install mesa-common-dev Reading package lists... Done Building dependency tree ...
10
votes
2answers
1k views

Is there Ubuntu's analogue of snapshot.debian.org?

Debian users have a kind of "wayback machine": snapshot.debian.org , which is really great. There are regressions sometimes, and if I don't have local deb package with old version, I'm getting sad ...
0
votes
1answer
3k views

How to install Python3.3.5 on Ubuntu Server 12.10?

I need Python 3.3.5 on Ubuntu Server 12.10. I want to run apt-get install python3 but I am not sure this will lead to Python3.3.5 version installation. In other words: how can I install the exact ...

15 30 50 per page