Linked Questions

766 votes
40 answers
1.3m views

How do I remove old kernel versions to clean up the boot menu?

Every time I install a new Linux kernel, it gets left in the grub_config, making the boot menu longer each time. I know I can manually search through the installed packages and remove them. Does ...
642 votes
24 answers
746k views

How do I free up more space in /boot?

My /boot partition is nearly full and I get a warning every time I reboot my system. I already deleted old kernel packages (linux-headers...), actually I did that to install a newer kernel version ...
user6722's user avatar
  • 6,695
150 votes
7 answers
138k views

Can't upgrade due to low disk space on /boot

I try to do do-release-upgrade but then I get: Not enough free disk space The upgrade has aborted. The upgrade needs a total of 25.7 M free space on disk '/boot'. Please free at least an ...
clamp's user avatar
  • 1,699
109 votes
2 answers
140k views

Why is gksu no longer installed by default?

I have always recommended pressing ALT+F2 and typing for example gksu nautilus or gksudo nautilus both are equivalent; to run graphical programs with root privileges. However, I have just installed ...
Warren Hill's user avatar
27 votes
8 answers
30k views

Bash one-liner to delete only old kernels

I've seen lots of threads on how to free space on the /boot partition and that is my objective as well. However, I'm only interested in deleting old kernels and not each one of them but the current ...
Alejandro's user avatar
  • 271
31 votes
4 answers
255k views

"error: XDG_RUNTIME_DIR not set in the environment." when attempting to run nautilus as root

I am attempting to run nautilus as root but when I run "sudo nautilus" from the terminal, I get the following error: error: XDG_RUNTIME_DIR not set in the environment. (nautilus:9341): Gtk-...
quantumbutterfly's user avatar
18 votes
4 answers
104k views

Failed to connect to Mir: Failed to connect to server socket: No such file or directory

After logging in as another user how do I run GUI programs? thufir@doge:~$ thufir@doge:~$ sudo -u hawat -i hawat@doge:~$ hawat@doge:~$ whoami hawat hawat@doge:~$ hawat@doge:~$ pwd /home/hawat ...
Thufir's user avatar
  • 4,551
11 votes
4 answers
20k views

Unable to upgrade kernel after 4.16.3

I'm running on Ubuntu 16.04 with 4.16.3 Kernel, both on my desktop and laptop, every time I try to upgrade to a newer kernel with UKUU fails the configuration of the package and return me this error (...
Fabi0_Z's user avatar
  • 113
10 votes
2 answers
43k views

What is the lastest stable kernel and how to install it? [duplicate]

I face a problem with installing kernel 4.6 on Ubuntu 16.04 . Someone said because it was unstable. So What is the latest stable version of kernel and how to install it.
CatCoder's user avatar
  • 659
14 votes
3 answers
8k views

purging old kernels fails to remove old initrd files

Can't explain why... I assume it isn't safe to simply manually delete them, so some guidance would be appreciated. Here's a ls of my /boot directory (obviously, I'm running the 3.13.0-51 kernel): -rw-...
Christopher Scott's user avatar
3 votes
2 answers
13k views

How do I update kernel to the latest mainline version? [duplicate]

Currently I'm running opensuse 13.2 and I want to update it to a (ubuntu)linux with the newest kernel the 4.9.xy release as mentioned at http://www.kernel.org. Is the latest kernel 4.9.xy version ...
zero's user avatar
  • 255
3 votes
3 answers
7k views

How can I tell if /boot has free space? [duplicate]

gksudo for Baobab Disk Usage Analyzer doesn't show /boot. I recently removed several old kernels. How can I verify that I've freed up space in /boot? Backstory — I started spring cleaning because ...
UsagiYojimbo's user avatar
7 votes
1 answer
5k views

Pin kernel version

I have ubuntu 16.04; Installed kernel linux-image-4.13.0-31 update, but I didn't like it, so I decided I want to keep using 4.13.0-26 for now. How can I prevent the update from affecting the kernel ...
nosklo's user avatar
  • 383
5 votes
1 answer
7k views

Can I remove old kernels from /boot

When I run dpkg --list 'linux-image*', the output shows that I only have 4.10.0-37 installed: Desired=Unknown/Install/Remove/Purge/Hold | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-...
Ralph's user avatar
  • 875
6 votes
1 answer
4k views

Bash template to use zenity (or yad) to insert / edit / delete records in a file or database

I’m looking for a bash template that uses zenity or yad to maintain a list of records. The template could be a shopping check list with print option or it could be a list of servers to monitor ping ...
WinEunuuchs2Unix's user avatar

15 30 50 per page