Linked Questions

2
votes
1answer
9k views

How to install Python 3.6 in virtual environment? [duplicate]

I am using Ubuntu 16.04 which comes with python 2.7 and python 3.5 pre-installed. I am currently working on a project where it requires to install python 3.6 and some additional packages. I have ...
1
vote
0answers
8k views

Upgrade python from 3.5.2 to 3.6.2 in Ubuntu 16.04 LTS [duplicate]

How to upgrade python from 3.5.2 to 3.6.2 via terminal?
251
votes
8answers
506k views

How to make 'python' program command execute Python 3?

The python program command executes Python 2. Python 3 can be executed using the python3 command. How can Python 3 be executed using the python command?
164
votes
6answers
723k views

How do I install the latest Python 2.7.X or 3.X on Ubuntu?

I want to install the latest Python tarball on Ubuntu, downloaded from http://python.org/download/. Is this is a correct way to install? ./configure make make install If not, how do I do that?
25
votes
7answers
25k views

No module named 'gdbm'

I just finished installing python 3.5.1 on my Ubuntu, but am faced with this error message, regardless if I'm installing with Anaconda or with apt-get: No module named 'gdbm' that normally displays ...
20
votes
4answers
31k views

ImportError: cannot import name _remove_dead_weakref

I've tried searching around but haven't been able to find a good fix or anyone else with this specific error. It happens after I try to install screen with apt-get install screen. Error: Setting up ...
19
votes
2answers
9k views

Gnome terminal will not start

I just tried to install python 3.6 on my Ubuntu 16.04 system, and now I cant run the terminal from the launcher or from Ctrl+Alt+T. I tried to run gnome-terminal from XTerm and got the following ...
7
votes
3answers
43k views

Update Python 3.5 to 3.6 via terminal

Using Ubuntu 17.04. After update Python 3.5 to 3.6 via terminal according to https://askubuntu.com/a/865569/695385 still showing that version is 3.5.3. ~$ python3 --version Python 3.5.3 How is this ...
12
votes
1answer
33k views

How do I install Python 3.7 on Ubuntu 16.04 and 18.04? [duplicate]

I have several systems. Some are 16.04 mini-servers and I cannot update the OS yet. The others have been updated to Ubuntu 18.04. (The 18.04 version I used has Python 3.6.5 on it).
1
vote
1answer
8k views

Help Installing Python on Ubuntu

I'm attempting to install both the last version of python 2 which is currently 2.7.14 according to the site, and the latest for v3, even though I don't really need it. (Just to see if I can get any ...
4
votes
1answer
2k views

Why is Python 3.6 not available via official Ubuntu repositories? [duplicate]

Maybe this is the wrong forum for this question, in which case I apologise, but why isn't Python 3.6 in the official repositories for Ubuntu 16.04 LTS? According to this answer it seems like Python 3....
1
vote
1answer
3k views

ImportError: cannot import name 'multiarray'

I installed Python3.6 as described here: sudo add-apt-repository ppa:jonathonf/python-3.6 sudo apt-get update sudo apt-get install python3.6 Then I installed numpy as follows: sudo apt-get install ...
1
vote
1answer
5k views

Install python 3.7 with the 3.5 version already installed on ubuntu 16.04 [duplicate]

I almost broke my Ubuntu installation trying to install python 3.7 from the source using checkinstall. My question is how to install python 3.7 and it's equivalent ipython alongside with python 3.5 ...
1
vote
1answer
1k views

Ubuntu 16.04 virtualenvwrapper python3.6 path

I'm not sure if this should be here or in a python board however since this isn't happening anywhere else except on an Ubuntu 16.04 system I thought it might be the right place. I have a Ubuntu 16.04 ...
3
votes
2answers
3k views

Can't uninstall Python 3.6

I want to uninstall my 3.6 version without touching the original 3.5 version. So I ran sudo apt-get remove python3.6 but the output was: E: Unable to locate package python3.6 E: Couldn't find any ...

15 30 50 per page