Linked Questions

7 votes
3 answers
8k views

Force removal of unwanted linux-image-extra* packages

To make a long story short, I am stuck with a handful of unwanted, half-configured image packages that I am trying to get rid of: $ dpkg -l |grep linux-im iF linux-image-3.13.0-100-generic 3....
user avatar
  • 203
0 votes
1 answer
16k views

Help Installing AMD GPU driver in Ubuntu 18.04

I was upgrading my AMD GPU driver. The install failed and now I can't seem to remove it either. Has anyone had any luck with this? matiwal@MatiBuntu:~/Downloads/amdgpu-pro-18.30-633530$ ./amdgpu-...
user avatar
0 votes
1 answer
4k views

Broken package of Mariadb

I am stuck and I don't know what to do anymore. I am trying to install Mariadb and then for some kind of occassion these errors persist like glue. dpkg: regarding .../mariadb-client-core-10.3_1%3a10.3....
user avatar
  • 101
1 vote
1 answer
1k views

Unable to correct problems, you have held broken packages when trying to install PHP

I am new to using Ubuntu OS, I am trying to install PHP so that I can use the interpreter in for PHPStorm. The commands I have used: sudo apt-get update sudo apt install php then I get the following ...
user avatar
1 vote
0 answers
1k views

How to repair unmet dependencies in Ubuntu on Windows Subsystem for Linux

I'm having trouble upgrading packages in my WSL Ubuntu on Windows 10 Pro. I've been using this particular machine and installation of Ubuntu for 3 months, and would like to figure out how to avoid re-...
user avatar
  • 11
0 votes
2 answers
1k views

18.04 Will Not Boot After Failed Update

I rarely reboot. Tonight I had some updates that failed (one that I remember was python). I figured it was odd, so I would reboot and try updating again. Only now I get stuck on [ OK ] Started GNOME ...
user avatar
0 votes
1 answer
329 views

Tried to install a .deb and now I can't update or install anything

I wanted to give weechat a try on my Ubuntu 15.04 install so I downloaded a stable .deb from here (https://weechat.org/download/debian/) but I think I missed a few instructions because now everything ...
user avatar
  • 133
0 votes
0 answers
891 views

Can not update live server (insserv rejected the script header error)

What can be done to fix it? root@lalala:/usr/share/nginx/html# apt upgrade Reading package lists... Done .... .... .... (Reading database ... 114395 files and directories currently installed.) ...
user avatar
1 vote
0 answers
623 views

Error upgrading to ubuntu 16.10 [duplicate]

I have an error upgrading ubuntu from 16.04 to 16.10, now i have this: apt-get -f install dpkg: error processing package libc6:amd64 (--configure): package libc6:amd64 is not ready for ...
user avatar
  • 111
0 votes
1 answer
556 views

Matplotlib is not installing on Ubuntu 16.04 [duplicate]

I have installed Ubuntu 16.04.2 LTS. I need to install the matlibplot python module. But whenever I try to install it with the command: sudo apt-get install python-matplotlib it shows the ...
user avatar
  • 101
0 votes
1 answer
479 views

to remove broken packages 14.04

I want to remove/reinstall the broken package libopenni-sensor-primesense0 I have tried all commands i.e sudo aptitude install <packagename> sudo aptitude -f install <packagename> sudo ...
user avatar
  • 1
3 votes
1 answer
446 views

Cannot clean up the /boot drive [duplicate]

I am trying to clean up my /boot drive but I feel like I'm in a vicious circle. What I have tried so far is this: $ df -h /dev/xvda1 236M 230M 0 100% /boot $ ...
user avatar
3 votes
1 answer
125 views

Unable to delete packages

I am not able to delete the following 2 packages : virtualbox-dkms virtualbox-ext-pack When I do sudo apt-get purge virtualbox-ext-pack it returns the following: Sub-process /usr/bin/dpkg ...
user avatar
  • 268
0 votes
0 answers
26 views

How do I reinstall opera-stable? [duplicate]

I'm on Ubuntu 20.04 and I cant install or remove programs, it just gives me the error "E: The package opera-stable needs to be reinstalled, but I can't find an archive for it." How do I fix ...
user avatar
  • 23