Linked Questions

4 votes
2 answers
10k views

Why an old Nodejs version is installed on my Ubuntu machine [duplicate]

I installed Nodejs on my Ubuntu: $ cat /etc/os-release NAME="Ubuntu" VERSION="16.04.6 LTS (Xenial Xerus)" ID=ubuntu ID_LIKE=debian PRETTY_NAME="Ubuntu 16.04.6 LTS" ...
Hairi's user avatar
  • 153
1 vote
1 answer
3k views

Not able to install nodejs in ubuntu command line [duplicate]

I have tried this: sudo apt install nodejs Getting Error this: Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. ...
Rupesh Kumar Sahu's user avatar
-1 votes
1 answer
2k views

Can't install any version of nodejs >10 (10,12,13) in my lubuntu [duplicate]

I typed following command on my lubuntu terminal from the nodejs download page to install 13.x version : curl -sL https://deb.nodesource.com/setup_13.x | sudo -E bash - sudo apt-get install -y nodejs ...
SAARTHAK JOHARI's user avatar
0 votes
3 answers
301 views

Installing Current nodejs version [duplicate]

Starting to learn Nodejs in Ubuntu (New to ubuntu as well). when I use apt install nodejs , v8.x.x is getting installe instead of current v12.x.x. I tried to use nvm using from here but it is only ...
Ran94's user avatar
  • 3
0 votes
0 answers
286 views

Problems installing Nodejs as a tarball [duplicate]

I downloaded NodeJS from the official website as a tarball and extracted it but I can't install it. The BULDING.md file says I should ./configure then make -j4 However, trying ./configure inside ...
Samuel's user avatar
  • 103
0 votes
1 answer
157 views

what's the canonical way to install nodejs on an Ubuntu desktop (21.x)? [duplicate]

I understand that apt is NOT the regular way I see 3 options: download and run an opaque script from the nodejs sites umake (https://wiki.ubuntu.com/ubuntu-make) asdf (https://asdf-vm.com/) I'd like ...
user1632812's user avatar
0 votes
0 answers
86 views

How to install downloaded app? [duplicate]

In Windows there is a wizard for the installation. How does that work in Linux/Ubuntu? Example: I downloaded https://nodejs.org/dist/v14.17.4/node-v14.17.4-linux-x64.tar.xz. How can I install it and ...
Ero Stefano's user avatar
2 votes
1 answer
79 views

Unable to compile 'syllable-5.0.0' (tar.gz) because node is not 12+ [duplicate]

I am on Ubuntu 20.04. I am trying to install a syllable counting program from source. Ref: https://github.com/words/syllable From readme.md This package is ESM only: Node 12+ is needed to use it and ...
brane stormer's user avatar
0 votes
0 answers
32 views

Problems with basics [duplicate]

I found out it is possible to run ubuntu on a USB. So thats what i tried and it worked. I wanted to test an express application but installing node js throws an error everytime. sudo apt install ...
Venox's user avatar
  • 1
0 votes
0 answers
27 views

How to install Node.js v12.x: [duplicate]

My Ubuntu version is 18.04.3 LTS. I am trying to install Node.js v12. but i can see that Version: 8.10.0~dfsg-2ubuntu0.4 can only be installed in my ubuntu . How to upgrade the version of node from 8....
Abhinav Kumar's user avatar
238 votes
15 answers
403k views

How do I make my terminal display graphical pictures?

This is a quick mockup I copy and pasted together. I imagine this being super cool and useful. Does something like this exist already?
Dennkster's user avatar
  • 2,483
149 votes
10 answers
506k views

How do you update npm to the latest version? [duplicate]

I'm having issues with npm in a Vagrant box I'm setting up. I noticed that the npm version is somewhat old, so I wanted to check the problem with the latest release. It is my understanding that you ...
Oliver Salzburg's user avatar
25 votes
6 answers
102k views

How to update Node.js to the long term support version on Ubuntu 20.04?

I'm pretty new to Ubuntu. I could install Node.js to the latest version 14.7.0 but the program I'm using (Jhipster) tells me that I need to install the Long Term Support (LTS, currently 12.18.3) and ...
Mike's user avatar
  • 363
16 votes
6 answers
32k views

bower install does nothing, not even throw an error

I am on Ubuntu 14.04. I did sudo apt-get install npm. Then I did npm install -g bower, which was successful. With which npm, I get /usr/bin/npm/. With which bower, I get /usr/local/bin/bower. I ...
corvid's user avatar
  • 347
10 votes
3 answers
15k views

Installing Node.JS through a PPA does not fetch the latest version

yeah yeah I know, this has been asked before. But when using the chris-lea ppa or the "official way" (which I think is actually the same thing?), after installing you get this: ~$ node --version v0....
yuvi's user avatar
  • 1,017

15 30 50 per page