Linked Questions

973 votes
7 answers
3.4m views

How can I add a user as a new sudoer using the command line?

After I add a user using adduser, I can't see it via System > Administration > Users and Groups unless I log out and then log in again. Is that normal? Also, can I set a newly added user as a sudoer ...
David B's user avatar
  • 11.1k
44 votes
5 answers
49k views

How to NOT become a root user? Are administrators root?

I installed Ubuntu on my PC. To log in, I use the username and password I created during installation. Does this mean I am a root user? If yes, then how do I become non-root? It looks like non-root ...
FirstName LastName's user avatar
15 votes
2 answers
19k views

Why am I suddenly not a sudoer anymore? [duplicate]

I booted up Ubuntu 12.10 today, and when trying to sudo, I entered my password as usual but it had said I'm not a sudoer. So I go and check my account under User Accounts, and for some reason Im now a ...
Freddyt99's user avatar
  • 303
13 votes
2 answers
26k views

How can I restrict program access to other users?

I'm setting up a new user account, and I want to allow access to only certain programs for just that account. How would I go around doing that?
Lyrositor's user avatar
  • 1,018
4 votes
4 answers
19k views

Sudoers.d Permissions denied

I am running ubuntu 14.04 in DardDrive. I was taking the Steps for Setting up and Running sudo located here http://snag.gy/JAGgt.jpg. But every I type sudo "whatever" as user ($), I get the following ...
Ken Sandoval's user avatar
2 votes
1 answer
6k views

What is the difference between the group root and the group sudo? Why root user by default is not a member of the group sudo?

I am quite confused regarding this matter. As far as I know the user root has all the privelages. Also all the users of the group sudo has all privelages. But the user root by default is not a ...
rancho's user avatar
  • 4,036
1 vote
1 answer
5k views

Run as group fails (sudo -g)

I would like to run a command with temporary group membership but it seems that I don't have permission to do that. As an example, if I run sudo -g internet ls, I get the message Sorry, user ...
rudivonstaden's user avatar
4 votes
2 answers
3k views

Allow user to execute sudo commands

I've looked at How do I add a user to the "sudo" group? and added user (say 'abc') to sudo group But now when user 'abc' tries to use sudo commands ubuntu says, 'abc' is not in sudoers list,...
wisemonkey's user avatar
  • 3,413
2 votes
2 answers
3k views

Is there a way to create a user with username "admin"?

Is there a way to create a user with username admin? When I tried to pick a username admin I got this error/ warning message. The username you entered (admin) is reserved for use by the system. ...
PRATAP's user avatar
  • 22.5k
1 vote
2 answers
273 views

Ambiguous disk usage statistics on EC2

I got the following problem: df -h shows: ubuntu@:~$ df -h Filesystem Size Used Avail Use% Mounted on /dev/xvda1 32G 9.6G 21G 33% / udev 819M 12K ...
Rubaiyat's user avatar
1 vote
1 answer
158 views

Prevent other users to login as me and view my files

My Ubuntu user account name "user-3121" with type as "Administrator". There is one more account named "sysadmin" with type as "Administrator". How do I know whether "sysadmin" can login as me and view ...
verstappen_doodle's user avatar