Linked Questions

414 votes
9 answers

How to get to the GRUB menu at boot-time?

My system is not dual-boot, I run a standard Ubuntu desktop system "on the metal" (I think running it in a VM is the same). Pressing c while booting does not cause the GRUB menu to appear (which I ...
  • 24k
232 votes
3 answers

How do I add a kernel boot parameter?

I need to add the boot parameter foo=bar to my kernel. How can I do this once for testing, and permanently if testing was a success?
  • 63.4k
33 votes
5 answers

Can I boot memtest86+ if I'm using UEFI?

Downloaded the Ubuntu 16.04.2 .iso install disk and flashed it onto a USB stick. Booting on the USB stick, there is no memtest86+ option (along with "Try Ubuntu"). Is there a way to add it to the ...
  • 797
13 votes
1 answer

Run memtest in terminal [duplicate]

I am running Ubuntu from flash drive and I would like to run memtest in terminal mode as multiple processes, I see file resides in boot directory but not able to execute as I get message "permission ...
12 votes
4 answers

How do I tell ubuntu not to use certain memory addresses?

I'm sorry if this is poorly worded, but I've done a memory test on one of my computers, and certain memory addresses have errors. This is the first time I've searched. If you need more information, ...
  • 125
12 votes
1 answer

How do I check system health?

I want a report on my system health, so that I know that all my hardware components (CPU, memory, disks...) are functioning as expected. It would be easiest to read if the report listed only the ...
  • 20.1k
5 votes
5 answers

Ubuntu Server 20.04 setup stuck at "Block probing did not discover any disks"

I'm trying to install Ubuntu Server 20.04 on a remote server. Problem is, I cannot attach a USB drive and the hosting provider does not allow me to mount ISO images, all I have is a pre-installed ...
  • 691
14 votes
2 answers

Diagnosing and fixing random Ubuntu crashes without SysReq?

I have read this question and tried to follow the selected answer's advice. I have also read this question but the second question I believe is unrelated to my issue. (But I'm not sure.) When Ubuntu (...
  • 215
5 votes
3 answers
8k views Failure

I have an intermittent problem with org.freedesktop.systemd1 failing. It seems to be happening at night (I leave my computer on at all times), and freezes the desktop to the point I have to do a hard ...
0 votes
3 answers

Chrome/Firefox slow to start in 14.04

It's been like that for months. Chrome and Firefox are just horribly slow to start. It can take 10 minutes before Chrome is usable. But after these 10 minutes, I can do whatever I want with it and it'...
  • 121
0 votes
0 answers

Ubuntu goes to a black screen after grub after a ram upgrade

Ubuntu works fine with my old ram stick but whenever I put in this new ram stick I bought it just shows a black screen after the grub menu, regardless of configuration(including just having the new ...
0 votes
1 answer

14.04 only works through recovery though badly

since I upgraded from 12.04 to 14.04 I can't boot in any other mode than through recovery mode. If I don't, the mouse hardly works then freezes, same for keyboard. Still, after using the recovery mode ...
  • 1
0 votes
0 answers

Ubuntu servers 22.04 shutsdown after some time

I manage a server for a friend. This server ran fine but when I tried making it go to sleep at a specific time and wake up using a cronjob, the server would not wake up using rtcwake. While trying to ...