Linked Questions

21 votes
2 answers
59k views

How do I run a script as sudo at boot time on Ubuntu 18.04 Server? [duplicate]

How do I run a script as sudo at boot time? I need to run ethtool --offload <net> rx off to disable the annoying jme udp checksum error message.
  • 311
17 votes
1 answer
55k views

Run terminal sudo command at startup [duplicate]

I need to run the following command at startup or upon login to make my samba share accessible to my file system. How can I make this command run when I start my computer? sudo smbnetfs ~/Shared -o ...
  • 461
4 votes
2 answers
24k views

How do I run a script on startup as superuser? [duplicate]

I want to run a command on startup on my Ubuntu Server. Does anyone know how to do this? Does /etc/rc.local run as superuser? Any help will be appreciated. Thanks!
  • 73
1 vote
1 answer
14k views

Running script via crontab on reboot [duplicate]

I am using Ubuntu Server 16.04. Everytime I log in, I need to manually run my script: /home/user/ini.sh. This script calls other scripts that need sudo permissions, so I get the prompt, insert my ...
0 votes
1 answer
5k views

How can I run a sudo sh at startup? [duplicate]

I'm not sure how this is a duplicate of anything that was mentioned. The script I'm trying to run needs Sudo to work, none of the answers say anything about getting a script that needs "super user" ...
0 votes
2 answers
4k views

.py script to run at the startup [duplicate]

I use 17.04 and rc.local is gone(I couldn't do it with rc.local anyway). I just want this two commands to run at the startup; cd Folder python3 file.py That's it. I looked all the similar answers ...
  • 1
0 votes
2 answers
1k views

How to automatically run a command at startup as root [duplicate]

I know that one should never want to do this, but I need to run a command as root at startup. For some reason the driver for my wifi card isnt recognized so to get it up and running I have to run ...
2 votes
2 answers
1k views

Run root script or command as root in startup application in Ubuntu 14.04 [duplicate]

I have a wireless adapter that used to work in ubuntu 13.10 (dwa 171) after installing drivers for it. Now it won't work the same way anymore since I upgraded to ubuntu 14.04. I've found the only way ...
0 votes
1 answer
668 views

Have to run rmmod b43 ; sudo rmmod bcma ; sudo rmmod wl ; sudo modprobe wl after restart? [duplicate]

I have a Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01) and unless I run rmmod b43 ; sudo rmmod bcma ; sudo rmmod wl ; sudo modprobe wl after restart, the wireless device isn't ...
1 vote
3 answers
197 views

How can i make a selfstarting script [duplicate]

I have an TL-WN727N wireless adapter connected to my laptop. Every time I start my laptop I must manually enter those two commands in a terminal: echo 'install rt2800usb modprobe --ignore-install ...
-1 votes
1 answer
69 views

Excecuting file at startup [duplicate]

I am trying to start a script at boot and i can't seem to get it to work. I made the file, put it in /etc/init.d, made it executable by chmod +x file.sh, and did update-rc.d file.sh defaults 100. Is ...
50 votes
26 answers
105k views

Mouse cursor invisible after 15.04 update

My mouse pointer became invisible after some updates after I upgraded to 15.04 from 14.10. In all standard settings the mouse pointer is activated (system settings, dconf...) I also tried different ...
  • 669
54 votes
7 answers
48k views

Host name reverts to old name after reboot in 18.04 LTS

This may be related to running 18.04 LTS as a virtual machine (Host is Win 2016 DC) but I can't figure it out how. I have tried every method of I know of to change the hostname but it always reverts ...
21 votes
2 answers
41k views

After upgrade to 16.04 LTS rc.local is not executing a command

On previous installed version kubuntu 15.xx i added a line into /etc/rc.local - /home/diet/scripts/my-auto-mount-script which obviously referred to a script that if on home wifi network drives should ...
  • 317
13 votes
3 answers
21k views

Startup script with sudo in Ubuntu 16.10

I need to start a script and a binary file from /usr/bin at startup with sudo/root privileges. I've tried many guides from this forum but nothing worked (rc.local and systemd style, Upstart) - maybe I'...
  • 183

15 30 50 per page