Linked Questions

0
votes
0answers
17k views

Downgrade gcc from 4.8 to 4.7 [duplicate]

I have downloaded the latest version of ubuntu Desktop 14.04.1 LTS. The gcc version is gcc (Ubuntu 4.8.2-19ubuntu1) 4.8.2. I would like to change it to the 4.7.2 20130108 [gcc-4_7-branch revision ...
2
votes
1answer
2k views

Change C++ version [duplicate]

I am trying to change the C++ compiler version. I have both, 4.6.x AND 4.4 versions, I want to set it to the 4.4 version, so I am doing: export "CXX=g++-4.4" But when I run the command: g++ -v I ...
0
votes
0answers
2k views

Switch between two version of gcc [duplicate]

By default my system uses gcc 5.4.0 in ubuntu 16.04 to run a specific program l need to switch to gcc 4.8. My question is the following : How can l switch to gcc 4.8 before running the program and ...
1
vote
0answers
83 views

How to call a older version gcc? [duplicate]

My ubuntu is 14.04, the default gcc and g++ is 4.8, I installed gcc and g++ 4.4 manually, so how can I specify the older version of gcc to call when I compile a program?
0
votes
0answers
28 views

g++ version does not seem to change even after installation [duplicate]

I currently have the g++ version 5.4.0. I wanted to install 7.3.0 I am using Ubuntu 16.04. I have followed these instructions: Dependency issues while installing gcc 7.3 from Jonathon F's PPA. ...
315
votes
9answers
646k views

How to make 'python' program command execute Python 3?

The python program command executes Python 2. Python 3 can be executed using the python3 command. How can Python 3 be executed using the python command?
129
votes
4answers
293k views

How do I use the latest GCC on Ubuntu?

I want to compile my program with the latest version of gcc. Ubuntu 14.04 comes with gcc 4.8.2, however there's 4.9.0 available, moreover, I see that it is available as a package: gcc-4.9. I tried to ...
80
votes
7answers
263k views

Getting + installing gcc/g++ 4.9 on Ubuntu? [duplicate]

How do I install the latest version of gcc and g++? I am using a variety of C++11 and C++1y features; which is why I need this.
58
votes
8answers
127k views

How do I Install CUDA on Ubuntu 18.04?

Is there any tutorial to install CUDA on Ubuntu 18.04? The instructions on the Nvidia website for 17.04 and 16.04 do not work for 18.04. I get a message telling me to reboot then re-run the ...
8
votes
2answers
24k views

How to use GCC 4.7 in place of 4.6?

So I'm working on a project and I wanted to use some C11 features for C. To use those features GCC 4.7 is required, so I went to synaptic and looked up 4.7, and I found the packages gcc-4.7-base so I ...
2
votes
1answer
6k views

Makefile 42: recipe for target 'util.o' failed

I am getting this error: ~/Distrib$ make all /usr/bin/g++ -O3 util.cc -I/home/shah/Distrib util.cc: In function 'into countLines(const char*)': util:19:8: error: 'exit' was not declared in this ...
3
votes
1answer
9k views

Install gcc 5 on Ubuntu 18.04

I have gcc 7.3.0 on Ubuntu 18.04. But I am working on a project where I need gcc less than version 6. When I tried to install gcc 5.4, I got this error: $ sudo apt install gcc-5.4 Reading package ...
6
votes
1answer
5k views

Building webkit from source

I tried to install the webkit applicaion from sources using this manual: https://help.ubuntu.com/community/WebKit When I type: ./autogen.sh --prefix=/usr the following error occurs: checking for ...
1
vote
1answer
6k views

diff between x86_64-linux-gnu-gcc and plain old gcc?

I'm trying to compile something called a "Voice Cloning Toolkit" for Festival and HTS. (see: http://homepages.inf.ed.ac.uk/jyamagis/software/page37/page37.html) I've found that lots of things break ...
1
vote
1answer
4k views

How to upgrade gcc-5 to gcc-7 in Ubuntu 16.04?

This is a follow up question to How to install gcc-7 or clang 4.0?. Following the answers therein, I was able to install gcc-7.2 by: sudo add-apt-repository ppa:ubuntu-toolchain-r/test sudo apt-get ...

15 30 50 per page