Linked Questions

4 votes
3 answers
878 views

Why does apt removes unwanted packages when giving * as suffix? [duplicate]

I did a sudo apt-get remove ruby* and then I saw that some grub packages were being removed too so I went to installed back those packages which log showed to have removed I set grub to work on my /...
1 vote
1 answer
774 views

What is the difference between fglrx* and fglrx? [duplicate]

Is there a difference between fglrx* and fglrx? What is the meaning of * if added?? I did use the following steps because I was not sure whether I've had a graphic driver or not. So I wanted to ...
  • 13
706 votes
9 answers
1.8m views

What is the correct way to completely remove an application?

I've searched the net for such information and found different command lines, like these ones: sudo apt-get remove application sudo apt-get remove application* sudo apt-get remove --purge ...
  • 7,493
59 votes
3 answers
6k views

Can 'sudo apt-get remove [write]' destroy my Ubuntu?

I wanted to remove my 'write' app, so I found this on a site: To remove a package type: sudo apt-get remove [package_name] So I typed: sudo apt-get remove [write] And afterwards I agreed on the ...
37 votes
5 answers
175k views

How do I remove the proprietary ATI drivers?

I've installed 11.10 and the proprietary ATI drivers using "additional drivers" The performance of my system is absolutely awful and it shouldn't be. I tried to remove the proprietary drivers using ...
33 votes
7 answers
153k views

How to remove desktop environments?

I installed few environments that I wanted to try out on Ubuntu 12.04, but none of them worked at all. It could be that I installed them all at the same time, meaning the OS didn't get a chance to ...
23 votes
6 answers
32k views

Ubuntu system is broken after accidentally uninstalling many packages

I accidentally removed all the packages starting with the name jpeg with: sudo apt-get remove jpeg* This screwed up a lot of things, removed Unity, Firefox, Flash player etc. I somehow managed to ...
18 votes
2 answers
32k views

VirtualBox 5.0 installation has broken VirtualBox packages on Kubuntu 15.04

Seeing that there was a new VirtualBox release, I tried to install it on Kubuntu 15.04... However, now all of my VBox 4.3 packages in the ubuntu repositories are broken (Virtualbox is provided by ...
  • 323
22 votes
2 answers
14k views

After the upgrade to 17.10 I only get a black screen. How do I fix this?

I used the upgrade manager to upgrade from 17.04 to 17.10. When I start the machine, I only get a black flickering screen now. I was using the nvidia binary drivers before the upgrade. NOTE: This ...
  • 9,989
8 votes
1 answer
6k views

Shorter way to apt-get install php7.0-{some modules}

I am currently installing php7.0 and was wondering if there is an shorter way to install the modules. normally I type: apt-get install php7.0 php7.0-fpm php7.0-mbstring php7.0-mcrypt php7.0-...
1 vote
1 answer
11k views

Unable to remove wine [duplicate]

I tried to remove wine but it says that virtual packages like wine can't be removed. Also I am unable to find my .wine file.
  • 11
3 votes
1 answer
13k views

How to remove redmine from ubuntu 12.04

Log: :/opt/maven$ sudo apt-get -f install redmine-sqlite Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to ...
  • 31
4 votes
3 answers
495 views

Why doesn't usage of '*' always work on zsh?

I ran the following command on zsh sudo apt-get install rhythmbox* It produced an error, when I ran the same command in bash it worked. Why does this happen? How can I make the above command work ...
  • 197
3 votes
2 answers
4k views

Remove all development libraries

I've built a few apps from source which required development libraries. And when I installed them, they installed more -dev dependencies. Now I want to remove those libraries. The command sudo apt-...
  • 9,173
3 votes
2 answers
3k views

How do I make space on /boot?

How do I free up space on /boot? ls /boot/ abi-4.2.0-16-generic memtest86+.bin abi-4.2.0-19-generic memtest86+.elf abi-4.2.0-22-generic memtest86+_multiboot.bin ...
  • 888

15 30 50 per page