Linked Questions

10 votes
1 answer
60k views

The "resolv.conf" file becomes empty after each restart [duplicate]

The "/etc/resolv.conf" file becomes empty after each restart and I lose the DNS data set in it. It only contains the following text each time: # Generated by NetworkManager What should I do?
B Faley's user avatar
  • 424
1 vote
1 answer
22k views

Static DNS in Ubuntu Server 16.04 [duplicate]

I am a complete new-be when it comes to Linux and even more so when it concerns Ubuntu. I want to configure the IPv4 settings to have automatic assigning of IP address but manual assigning for DNS. ...
E Simon Vijay's user avatar
1 vote
1 answer
15k views

No write permissions on a file even with `sudo` [duplicate]

I modified /etc/resolv.conf to configure DNS for my VPN. Now I would like to modify it again but I can't. The operation is not permitted even if I use sudo nano /etc/resolv.conf I tried to start in ...
Anonymous's user avatar
  • 113
14 votes
0 answers
16k views

How To Auto Add To /etc/resolv.conf? [duplicate]

On Ubuntu 10.04 Server, you can edit a file and it will automatically add a nameserver to the /etc/resolv.conf on boot. Unfortunately, Ubuntu 10.04 Desktop does not have this feature that I'm aware of,...
Volomike's user avatar
  • 2,293
1 vote
4 answers
9k views

DNS Resolution fails, and /etc/resolv.conf isn't persistent, how can I force the use of certain DNS servers? [duplicate]

I have this persistent and annoying issue. When I first boot up, my desktop can't resolve any DNS names unless I edit the /etc/resolv.conf file and remove the entry for name-server 127.0.0.1 and ...
Brian Fleishman's user avatar
2 votes
0 answers
441 views

/etc/resolv.conf managed by NM? [duplicate]

Possible Duplicate: How do I add a DNS server via resolv.conf? I discovered (with great disappointment) that in 12.04 the file /etc/resolv.conf no longer contains the real nameserver IP, but just ...
Fabio's user avatar
  • 582
0 votes
0 answers
107 views

How to use DNS instead of /etc/hosts? [duplicate]

In /etc/hosts, I can for example input 127.0.0.1 example.com Now I have a nameserver (pdns with postgre-backend), which I want to use in the intranet. So, I tell my dns server, that example.com ...
WitchCraft's user avatar
  • 1,874
22 votes
6 answers
20k views

Can't connect to Google Starbucks wifi on Ubuntu 17.10

Bug Report Summary For some reason Ubuntu loses track of the IP address associated with the router URL that processes the login to the router. I posted an answer that addresses this. Look for the ...
Ole's user avatar
  • 1,507
18 votes
3 answers
178k views

ping: unknown host google.com in UBUNTU SERVER [duplicate]

I use Ubuntu Server 12.10. Why if I try: ping google.com ping bitbucket.org or any other website I have: ping: unknown host google.com ping: unknown host bitbucket.org EDIT: ping 8.8.8.8 PING 8.8....
mamasi's user avatar
  • 305
1 vote
2 answers
14k views

Ubuntu Bind9 set up and resolv.conf

I found this tutorial the best I've come across and it works! Well done although I can't vote and comment on it due to my site privilege as yet. How do I do a complete BIND9 DNS Server Configuration ...
Mario's user avatar
  • 11
1 vote
1 answer
13k views

APT "Could not resolve 'in.archive.ubuntu.com'" [duplicate]

I am using Ubuntu 14.04 LTS and I am unable to use apt-get update command. I am getting the below error: support@node:~$ sudo apt-get update Err http://in.archive.ubuntu.com trusty InRelease Err http:...
Rishab Prasad's user avatar
1 vote
2 answers
10k views

Ubuntu 14.04 - Connection is there but no internet access - messed resolvconf

Let me start with a disclaimer: I have tried to fix my problem by reading similar questions & answers, but so far no luck. Not only that, but I think that by making some changes to resolvconf I ...
ArcM's user avatar
  • 11
1 vote
2 answers
4k views

internet issues after upgrading to Ubuntu 12.10

I upgraded to Ubuntu 12.10 using update manager. After the upgrade, the wifi gets connected but would not display any webpages. If I ping 8.8.8.8 or google.com, there is response. I managed to fix ...
Ubuntuser's user avatar
  • 9,836
1 vote
1 answer
4k views

apt-get not working on Ubuntu VPS

I couldn't install any software using apt-get command in my VPS and the terminal prints: root@ubuntu:~# apt-get install python3 Reading package lists... Done Building dependency tree Reading state ...
hamidfzm's user avatar
  • 981
0 votes
1 answer
3k views

Default search domain for /etc/resolv.conf

With systemd-resolved, where does DOMAINS in search come from? /etc/systemd/resolved.conf [Resolve] DNS=1.1.1.1 Domains=lan /etc/resolv.conf nameserver 127.0.0.53 search lan DOMAINS <---- lan is ...
nehz's user avatar
  • 101

15 30 50 per page