Linked Questions

0
votes
1answer
120 views

Completely prevent installation of Python 2? [duplicate]

I'm on Ubuntu 19.04 and I would like to make sure that if I try to install some software with a hard Python 2 dependency that it would just fail instead of installing 2 on my system.
1
vote
0answers
148 views

apt-get: How to find link for packages being installed (and skip them)? [duplicate]

I want to use TensorFlow on Ubuntu 16.04, which requires CUDA 9.0, not the latest 9.1. However, I previously had CUDA 9.1 installed. After running sudo apt-get remove --purge cuda* && sudo ...
2
votes
0answers
98 views

How do I freeze my ppa to the current installed versions? [duplicate]

I have two ppa added to my Ubuntu 16.04 installation and would like to freeze the current release that I have thoroughly tested. add-apt-repository ppa:certbot/certbot add-apt-repository ppa:...
1
vote
0answers
51 views

How to apt pin a future package from next version of ubuntu? [duplicate]

(Note: I understand I may need additional packages that have dependencies, and can work that out on my own, do not worry that I am asking about a single package). I have Ubuntu Mate Disco Dingo (19....
5
votes
3answers
5k views

Unable to decrypt text files with openssl on Ubuntu 18.04

I am unable to decrypt a number of text files I encrypted with openssl on Ubuntu 16.04. I always get this error message: $ openssl des3 -d < ~/ISRIC/credentials.txt.des3.old > ~/temp/...
2
votes
1answer
831 views

Mark Hold doesn't hold when apt-get dist-upgrade

How can I prevent apt from changing my kernel? When I create an ubuntu system where I want to lock the kernel, mark hold doesn't prevent kernel upgrade. Lock kernel and check the lock apt-mark hold ...
2
votes
0answers
366 views

APT pinning in preferences.d behaviour change from 14.04 to 16.04

I'm attempting to do the equivalent of holding a package via /etc/apt/preferences.d/something.pref in 16.04, and the behaviour seems to have changed from 14.04. Given some package foo that has an ...
1
vote
1answer
292 views

How to lock down one specific kernel out of several

I am currently on kernel 4.13.0-38-generic and I am happy to stay on the upgrade path, but I want to keep kernel 4.4.0-119-generic as-is (because virtualbox works for me on that one). Using synaptic, ...
2
votes
1answer
175 views

How to get icon buttons inside Apper software manager when used in Lxqt

I was looking for a light and fast software manager for KDE/Qt similar to Synaptic, and Apper is an answer. Although it is usable, and I find it even lighter than Synaptic, it lacks icons for the ...
0
votes
0answers
48 views

apt pinning for newer version of package failed

I have ubuntu 18.04, the default package for linphone version is 3.6, but i need to install a newer version which is linphone 3.12 which found on ubuntu 20.04 packages, although i don't need to ...