0

I have an old hardware x86 PC running 12.04.5. I had been ignoring the Update Manager and using the CLI for updates till recently when I decided to use Update Manager, BIG MISTAKE!!!! It hung my system and when I was able to reboot I had lost WiFi, all my printer setups, and more. Recovery mode did not help. I tried loading a driver for a Realtek 8192 dongle but the shell failed because the Manager had left the Modules incompatible with installed Essentials and Headers. I have been booting to the “Previous Version” from GRUB 2 (which has internet access). I want to remove the updated version from my system since I have no trust in what the Manager did. I would like to install the newer kernel and keep the presently working version as backup. Currently: kernel 3.2.0-126-generic-pae is GRUB 0, which is the bad version, no internet etc kernel 3.2-0-98-generic-pae is GRUB 2 which I can boot into to get internet access. Windows XP Professional is GRUB 5 which I need for the SCSI access, not an issue here

lsb_release -a yields the following No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 12.04.5 LTS Release: 12.04 Codename: precise

gnome-system-monitor: yields the following Release 12.04 (precise) 32-bit Kernel Linux 3.2.0-23-generic-pae GNOME 3.4.2 Hardware: (32 bit) Intel Pentium 4 CPU 3 GHz x 2, 1 GB memory

dpkg -l | grep linux-image yields the following ii linux-image-3.2.0-126-generic-pae 3.2.0-126.169 Linux kernel image for version 3.2.0 on 32 bit x86 SMP ii linux-image-3.2.0-23-generic-pae 3.2.0-23.36 Linux kernel image for version 3.2.0 on 64 bit x86 SMP ii linux-image-generic-pae 3.2.0.23.25 Generic Linux kernel image

I am not sure how the x86 versus the 64bit issue is affecting me. I only want a working system that can be updated to a known state. I would like to clean up the 3.2.0-126 so it can boot and not lose wifi. ("sudo apt-get update" did not do the job)

Any suggestions would be welcome.

(P.S) The old hardware has PCI cards for SCSI scanner access so I want to keep it but I tried 14.04 LTS once and it had graphics issues. Not my only PC so old versions of Ubuntu are fine.

  • Ubuntu 12.04LTS is past EOL (may-2017) and is thus off-topic. The only 12.04 still supported (by Canonical) is Ubuntu 12.04ESM which is not supported here; if you're using 12.04.5 ESM use the phone/email support. – guiverc Jan 26 '18 at 8:21
  • As noted, Ubuntu 12.04 is EOL. I'd recommend backing up user files and reinstalling a fresh copy of Ubuntu on your machine (you'd probably get better support overall for your hardware issues as well). – richbl Jan 26 '18 at 10:42
0

SOLVED the problem. I gave up and reinstalled 12.04 from CD. (By the way, how does one edit a post? I could find no links for editing anywhere on the site.) After posting "Solved" finally noticed the almost greyed out "edit" link.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.