0

I installed Ubuntu 17.10 in dual boot. But, in Ubuntu, I could not play sound from the speaker, while headphones worked fine. On Windows, both headphones and speakers worked fine.

So I found this post and applied the suggestion. That is, I opened

sudo gedit /etc/modprobe.d/alsa-base.conf

and I added the following line at the end

options snd-hda-intel model=generic

and then rebooted my PC.

Now the sound is completely broken. I cannot play any sound nor from the speaker nor from the headphones. Now from Ubuntu nor from Windows.

In particular, Windows show the sound icon in the task bar crossed off, and on Device Manager it recognizes an "Intel HD Audio" device, but it has the yellow warning icon next to it and, by opening the properties, it says that the device could not be started due to an error.

I have tried to revert the change and rebooted the PC, but this doesn't work.

What can I do? If I am unable to fix this I had to bring the PC into warranty.

I didn't expect to mess things up SO BAD.

  • Please run apport-bug alsa-base and report this bug. You can try to reinstall the original alsa-base.conf by running sudo apt install --reinstall alsa-base, then restart. If you've just been restarting rather than turning off your computer, you can turn off and unplug your computer (including disconnecting the battery if it's a laptop) for 30 seconds and see if it works in Windows and Ubuntu as before after starting it again. – Chai T. Rex Jan 25 '18 at 22:23
  • @ChaiT.Rex It worked after restarting the notebook without taking the battery off. The battery cannot be dismounted without removing the screws, which would invalidate my warranty. Why did this happen? I was really scared that I would have to bring the PC into warranty, losing one month of work – raffamaiden Jan 25 '18 at 22:32
  • @ChaiT.Rex I mean, it was either the restart, the reinstalling of alsa-base or both of them. I also installed the audio driver from the vendor site (on Windows), but that didn't solve the problem. Anyway thanks man! – raffamaiden Jan 25 '18 at 22:34

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.