0

I started using ocamlfuse to access google drive with Nautilus and it was functioning perfectly fine. The thing is, at some point I used, by accident, the sudo command, I'm not shure if it was to run ocamlfuse:

sudo google-drive-ocamlfuse

Or if I used it when mounting the folder

sudo google-drive-ocamlfuse ~/googledrive

After that, I can only mount the googledrive folder with the sudo command, and if I run

google-drive-ocamlfuse

I get this:

"Error: Sqlite3 error: READONLY"

Accessing just by using the sudo command gives me trouble when trying to open multiple documents with Libreoffice and some other applications at the same time.

  • I would start by checking (and correcting if necessary) the ownership of the configuration files described here: Configuration – steeldriver Jan 26 '18 at 0:14
  • Ownership from the files is ok, and apparently changing their permissons didn't work – Eduardo Flores Jan 26 '18 at 16:39
2

Run:

sudo chown -R your-username.your-username ~/.gdfuse

This will change the permissions of ~/.gdfuse/default/cache/cache.db back to your user's and then you can perform the command.

0

At the end I solved this by just removing the package using purge and autoremove. I also erased the .gdfuse folder in home so I could do a clean installation. The problem was solved doing this, in case someone wants to know.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.