I just purchased a hp probook 450 which came with pre-installed Windows 10 pro. I shrank the main partition in order to create a ubuntu partition with dual boot (ubuntu 16.04).

This has worked fine so far, until I tried to mount the main partition of my hard drive. The problem with the mount command is that I cannot determine the FS type of the windows partition. I would expect it is NTFS, but now I don't know for sure.

Thanks to fdisk -l, I know the device file for the partition I want to mount is /dev/nvme0n1p3, but the mount command does not work:

> sudo mount -t ntfs -o nls=utf8,umask=0222 /dev/nvme0n1p3 /win
NTFS signature is missing.
Failed to mount '/dev/nvme0n1p3': Invalid argument
The device '/dev/nvme0n1p3' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

I ran multiple commands to try to determine the file system, but without success.

The df does not show the partition I want to mount.

> sudo df -khT
Filesystem     Type      Size  Used Avail Use% Mounted on
udev           devtmpfs  7.8G     0  7.8G   0% /dev
tmpfs          tmpfs     1.6G  9.6M  1.6G   1% /run
/dev/nvme0n1p6 ext4       23G  5.9G   16G  27% /
tmpfs          tmpfs     7.8G   32M  7.8G   1% /dev/shm
tmpfs          tmpfs     5.0M  4.0K  5.0M   1% /run/lock
tmpfs          tmpfs     7.8G     0  7.8G   0% /sys/fs/cgroup
/dev/nvme0n1p7 ext4      3.9G  184M  3.5G   5% /home
/dev/nvme0n1p1 vfat      356M   69M  288M  20% /boot/efi
tmpfs          tmpfs     1.6G   52K  1.6G   1% /run/user/1000

The fdisk command shows all partitions, but does not display the FS type.

> sudo fdisk -l
Disk /dev/nvme0n1: 477 GiB, 512110190592 bytes, 1000215216 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: ......

Device             Start        End   Sectors  Size Type
/dev/nvme0n1p1      2048     739327    737280  360M EFI System
/dev/nvme0n1p2    739328    1001471    262144  128M Microsoft reserved
/dev/nvme0n1p3   1001472  896438271 895436800  427G Microsoft basic data
/dev/nvme0n1p4 953784320  957362175   3577856  1.7G Windows recovery environment
/dev/nvme0n1p5 957362176 1000204287  42842112 20.4G Microsoft basic data
/dev/nvme0n1p6 896438272  945266687  48828416 23.3G Linux filesystem
/dev/nvme0n1p7 945266688  953784319   8517632  4.1G Linux filesystem

The lsblk command shows no FSTYPE for the partition I want to access.

> lsblk -f
├─nvme0n1p5 ntfs   Recovery Image    
├─nvme0n1p1 vfat   SYSTEM           /boot/efi
├─nvme0n1p6 ext4                    /
├─nvme0n1p4 ntfs   Windows RE tools 
└─nvme0n1p7 ext4                    /home

Can anybody help me in mounting this partition ?

  • 4
    Did you turn off Windows fast start up or always on hibernation? askubuntu.com/questions/843153/… and: More explanation of NTFS driver & Windows hibernation askubuntu.com/questions/145902/…
    – oldfred
    Commented Jan 25, 2018 at 22:42
  • No: windows is shut down completely.
    – Gaetan
    Commented Jan 26, 2018 at 16:21
  • Normal shutdown is hibernation with Windows. You have to change settings to turn off the hibernation before shutdown. Linux will not work with hibernated Windows. And does not work with NTFS if the NTFS needs chkdsk to prevent damage to NTFS file structure.
    – oldfred
    Commented Jan 26, 2018 at 19:55

4 Answers 4


Thank you all for your answers. I tried them but it still didn't work. However, while looking at the disks utility in Windows, I noticed something that came out of my mind while installing: the disk is actually encrypted with bitlocker.

This is the reason why lsblk was not able to show the FS type. So, I went to this post and was able to decrypt and mount my Windows drive.


Please try exFat. Looks like that's a possibility based on the following page in wikipedia.


When I try it on my computer, it uses a FUSE module.

$ sudo mount /dev/sda1 /mnt/hdd
FUSE exfat 1.2.5

UPDATE: This site has a great article on exFAT in ubuntu. It's from 2015, but it might help.



I seem to recall that shutting down Windows 10 hibernates while a reboot does not. Try to access the partition after a Windows 10 reboot. If that fails you will need to disable fast startup.

  • Type Control Panel in the search box

  • Click Control Panel.

  • Click Power Options.

  • Click Choose what the power buttons do

  • Click Change settings that are currently unavailable.

  • Scroll down to Shutdown settings and uncheck Turn on fast startup.

  • Click Save changes.

Incidentally, using Disks or Gparted (within Ubuntu) to view the disk and partitions will confirm the FS type. FS location


If it's not ntfs you could try msdos.

man fs

msdos    is the filesystem used by DOS, Windows, and some OS/2 computers. msdos 
         filenames can be no longer than 8 characters, followed by an optional 
         period and 3 character extension.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .