1

Recently my workstation (Ubuntu 16.04 LTS) hung due to heavy load (compiling) and probably swapping. After waiting a long time, I choose to reboot with REISUB.

After reboot, everything seems to work normally, except workspaces. I initially thought that the keyboard shortcuts went misconfigured, but all other shortcuts work; Even changing shortcuts or resetting them does not work for workspaces.

It seems like the only way to switch workspaces is now to use the workspace swticher. I can also move windows between workspaces using this method, but it behaves somehow oddly... sometimes the window I just carefully placed, "jumps" to another location.

I then realized the problem must be with the workspaces themselves: with windows in different workspaces, when clicking on their icon in the unity launcher, the usual behavior was to move to the workspace the window was on, before giving focus to the window. This does not happen anymore: I am just left in the current workspace with focus on the current window.

The above makes me think that the OS is actually "trying" to switch, but it fails due to some error. However, I am unsure how to debug this.

Further things are noticed are: - newly opened windows sometimes get drawn with their title bar "outside" of the screen, and therefore cannot be moved around anymore. Strangely, the title bar does not appear on other workspaces (which I recall being the case when I misplaced windows before); - the shortcut to align windows to one side of the screen (by default ctrl + alt + numpad 6) does not work anymore, but the one for toggling maximization (ctrl + alt + numpad 5) does; - windows change position when I switch workspace with the workspace switcher.

Further info if it might be useful: - I do have compiz-settings-manager installed, but I tried to disable all plugins already, to no avail; - I have a 3 screen system, which worked fine for years, and cannot be the cause of the problem;

Since everything worked fine just before the "forced reboot", my guess is that some configuration file got corrupted. Can anyone provide help in resetting the system state, or track down the cause?

1

Shortly after posting this question, I found a partial solution here. It seems like a workaround to me, so I leave the question open in case someone knows a better way.

In any case, for future reference, activating "Desktop Wall" in compiz-setting-manager does solve the problem of moving windows to another workspace. But it seems not to solve the prblem with ctrl + alt + numpad 6, so I will investigate further.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.