0

I just installed Ubuntu 17.10 on my new mini-PC Vorke V1 plus (Intel Apollo Lake Celeron J3455). The fan spins up and down properly under Windows 10 but when running Ubuntu it runs at full speed constantly.

I ran sensors-detect and running sensors I get the core temperatures but not fan status. If I run sudo pwmconfig I get "usr/sbin/pwmconfig: There are no pwm-capable sensor modules installed" even after adding the acpi_enforce_resources=lax to the grub configuration.

I saw that there are 7 cooling devices and 5 thermal zones under /sys/class/thermal/. I can control fan speed by changing /sys/class/thermal/cooling_device0/cur_state from 0 (fan off) to 11 (max speed) but I can not guess how to configure ubuntu to manage speed automatically.

Best regards and thank you.

EDIT: I've tried also adding "acpi=off" to the /etc/defaults/grub file, in this case the fan runs at low speed (the default one set by bios at boot) and not change with the cpu load. Also in this case, in the /sys/class/thermal directory there is none of the cooling_devices and only two thermal_zones. Running the pwmconfig utility also gives me the "There are no pwm-capable sensor modules installed" message.

EDIT2: Ok I tried the second response which is oriented to Thinkpads. I installed the thinkfan package. I configured it as shown. When I run find /sys/devices -type f -name "temp*_input" I get:

/sys/devices/platform/coretemp.0/hwmon/hwmon1/temp2_input
/sys/devices/platform/coretemp.0/hwmon/hwmon1/temp5_input
/sys/devices/platform/coretemp.0/hwmon/hwmon1/temp3_input
/sys/devices/platform/coretemp.0/hwmon/hwmon1/temp1_input
/sys/devices/platform/coretemp.0/hwmon/hwmon1/temp4_input
/sys/devices/virtual/hwmon/hwmon2/temp1_input
/sys/devices/virtual/hwmon/hwmon0/temp1_input

In my thinkfan.conf I put those entries. The command sudo thinkfan -n gives me the message /sys/devices/platform/coretemp.0/hwmon/hwmon1/temp2_input: No such file or directory but the file exists and it is readable with sudo cat. If I delete the line of this entry (the first one) is the second one which gives the error and repeating procedure all of the entries give me the same error. I guess it is because the hardware is not a Thinkpad.

The third response is the same solution proposed in the accepted response which does not work in my case.

And the last response also does not work. The ik8 module fails to install with dell_smm_hwmon: unable to get SMM Dell signature message in dmesg.

  • 2
    Possible duplicate of How to control fan speed? – Elder Geek Jan 25 '18 at 15:11
  • @Elder Geek: As you can read in my question, I've already tried, without success, the accepted soultion in the possible duplicate. Other solutions in that question are more or less the same as the accepted or very focused to specific brands not related with mine. – Patxitron Jan 26 '18 at 8:20
  • You might notice that there are 3 other answers to that question. The accepted one is only that because the asker chose it. The other answers are there ostensibly because the accepted answer didn't work for everyone but appear to have worked for several. You might try all the answers before jumping to the conclusion that it's not a duplicate. Then edit your question with what you tried, what you expected and what happened when you did. – Elder Geek Jan 26 '18 at 14:45
  • OK, I tried the rest of the proposed solutions even though my hardware is neither Thinkpad nor Dell, without success. I think that definitely my problem is not a duplicate of the proposed one. – Patxitron Jan 29 '18 at 9:28
1

Finally I thought it would be less effort to program my own daemon, and that's what I've done: https://github.com/patxitron/vorke-temp-daemon

The daemon just reads all core temperatures and sets the fan speed acording to the highest one using a fixed table. Below 45C the fan stops and from 74C the fan is at maximum speed. It assigns different speeds for temperatures in between.

The loop runs four times per second and, at this moment, is a quick and dirty solution without hysteresis and with all paths and temperature settings hardcoded.

There are some improvements to be made, like the already said problem with hysteresis. It would be nice also to move the files from the temps are read, the file to which the fan speed is written and the table which assigns fan speeds to temperatures into a configuration file.

In the meantime, I hope it's useful for someone.

Best regards.

  • If you set this as a solution, it will me shown as answered to other users. – davidbaumann Jan 29 '18 at 13:48
  • If you would edit your answer to include the details regarding what your solution supports, your answer would likely be a merge candidate for inclusion in the called duplicate question, likely making it easier for members with the same issue to locate. If you need help dealing with the constantly changing fan speed you might ask the community at stackoverflow.com to help you refine your code. Cheers! – Elder Geek Jan 29 '18 at 14:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.