13

First off let me mention that this problem happened a while ago so i may have forgotten some of the details. A while ago I was trying to get used to backtrack5 and I was doing pretty well I think. I learned that you shouldn't be using root exclusively so i was creating a user account and trying to give it all the right permissions and access.

I don't remember what did it specially but this is part of the error message I'm getting from Xorg.0.log:

(II) Module nvidia: vendor="NVIDIA Corporation"
    compiled for 4.0.2, module version = 1.0.0
    Module class: X.Org Video Driver
(EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
(EE) NVIDIA:     system's kernel log for additional error messages.
(II) UnloadModule: "nvidia"
(II) Unloading /usr/lib/xorg/extra-modules/nvidia_drv.so
(EE) Failed to load module "nvidia" (module-specific error, 0)
(EE) No drivers available.

Fatal server error:
no screens found

Now knowing that this was a problem of my own doing I took a look at my history to try and figure out what i did wrong but i'm not very savvy in such things... I'll paste some of the relevant command history

My Pasted command history

I have an idea of what the problem might be but i have no idea how i would fix it. if anyone could help me it would be greatly appreciated. And if i should provide anymore information just let me know.

PS sorry if this is a bit verbose. And sorry that the command history isn't formatted properly for this site.

3
  • Sounds as if you need to install the nvidia driver help.ubuntu.com/community/BinaryDriverHowto/Nvidia
    – Panther
    Jan 30 '12 at 20:24
  • I checked that out and it almost seems reasonable but those are instructions for GUI. I have to do everything from the CLI. do you know how i would do that?
    – Guy0203
    Jan 31 '12 at 23:27
  • sudo apt-get install nvidia-current
    – Panther
    Jan 31 '12 at 23:32
19

I feel like an idiot. After months of forum joining, hopping, posting and prowling I finally found the answer

rm /etc/X11/xorg.conf
reboot
startx

That was it. But thanks for the help, guys.

3
  • 1
    anyone knows why removing xorg.conf solves the problem? I just spent hours trying to fix and removing this file just solved everything. Such stupidity. Nov 17 '18 at 15:14
  • I did the same just now and indeed, that solved my issue. xorg-server starts fine; I don't have mouse and keyboard input but I know how to resolve that issue. It's really annoying that the people who wrote xorg-server and the other parts, don't add such simple troubleshooting aids - the askubuntu.com site helped more than the xorg-hackers did here ...
    – shevy
    May 3 '19 at 23:04
  • This solved my problem. In my case, I had switched the storage device (SSD) from a computer with Nvidia graphics to one with intel and after installing the intel drivers and deleting the Nvidia drivers, I had the login loop and would only login in recovery mode until I deleted the /etc/x11/xorg.conf
    – geneowak
    Nov 4 '20 at 17:10
1

To install the nvidia driver from the command line use

sudo apt-get install nvidia-current

Then reboot, X should start. If needed, you then run nvidia-settings to make any adjustments. Run it as root to save your settings

gksu nvidia-settings
1

To the folks experiencing this issue, but with ATI drivers, see the following

https://askubuntu.com/a/225563/515315

basically:

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get install xserver-xorg-video-ati
sudo Xorg -configure
sudo cp /home/XXXXXXX/xorg.conf.new /etc/X11/xorg.conf

Hope this helps someone

1
  • I just ran the command. Now even virtual terminal is not coming.
    – xpioneer
    Aug 2 '20 at 8:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.