0

I'm getting the following error while trying to install ns2.35:

Error in `ns': free(): invalid next size (fast): 0x0000000000c7c850
Aborted

Are there any methods to bypass this error?

  • Please edit your question to include Ubuntu version. – Knud Larsen Jan 26 '18 at 1:26
0

'ns2.35' Howto : sudo apt-get install g++ g++-4.9 autoconf libtool libxmu-dev xgraph

tar xvf ns-allinone-2.35_gcc5.tar.gz https://drive.google.com/file/d/0B7S255p3kFXNVVlxR0ZNRGVORjQ/view?usp=sharing

cd ns-allinone-2.35/
export CC=gcc-4.9 CXX=g++-4.9 && ./install
cd ns-2.35/
sudo make install      ( 'make install' will copy 'ns' to /usr/local/bin/ )
cp ns ns-orig          ( this is your backup if you do changes to ns-2.35 )
sudo cp ns-orig /usr/local/bin/
cd ../nam-1.15/
sudo make install

That's it. No more to do. Simulation : $ ns file.tcl or $ ns-orig file.tcl

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.