69

I have installed both exfat-fuse and exfat-utils.

However, when I go to gparted, and attempt to format a partition as exFAT, the exfat option is greyed out when attempting to create or format a partition.

exfat greyed out when attempting to format an existing partition

exfat greyed out when attempting to create a new partition

Why is this so? How can I use gparted to create an exfat partition?

3
60

For GParted version v1.2.0 and above (Ubuntu 21.10 and above)

exFAT support was added in version 1.2.0 of GParted. To use exFAT you must install the exfatprogs package (and NOT exfat-utils). Installing exfatprogs will uninstall exfat-utils.

Install via the software center

exfat is now supported in GParted v1.2.0 with features "detect","read","create","move","copy","check","label", and "UUID", but not "grow" or "shrink"

There is also a requirement fo util-linux v2.18 and above. Ubuntu 21.04 is already at util-linux v2.36 so this isn't an issue unless you're manually backporting.

As of writing, GParted 1.2.0 is not yet in any version backports.

For GParted version below v1.2.0 (<= Ubuntu 21.04)

In View->File System Support, exFAT currently doesn't have support in gparted (0.28.1) for anything other than moving or copying.

enter image description here

No "required software" is listed, so it doesn't (yet) know about exfat-utils.

However, because:

  • the partition is a valid partition, and
  • its perfectly safe to move or copy (since the internals of the filesystem are not affected by a move)

the partition must be listed in the list of filesystems, but greyed out in this context.

If you must format a partition as exfat, then you can use gnome-disks (a.k.a. "Disks") as in this question: GUI tool for formating to exFAT

1
  • IMPORTANT POINT: Make sure to Unmount the disk first. Otherwise the options remain grayed out.
    – Reza Taba
    May 1 at 22:05
31

Much more simple: You can use the Ubuntu Disks app. It does it without needing any other add-on. Just open the Disks app, then choose "format partition". Then name your drive and Choose the option "Other" in order to choose the format.

Click "next" and then you will be able to select "exFat" formatting. Format and then you're all set!

Cheers!

PS: If it still remains greyed, then @K.-MichaelAye found a fix by installing:

sudo apt install exfat-utils exfat-fuse
5
  • 2
    Thanks LeChat. This is actually an answer to a different question, and the Ubuntu "Disks" app you refer to (a.k.a. gnome-disks) was already covered in my answer anyway. Aug 27 '18 at 4:25
  • 2
    also greyed on in disks for me on Ubuntu LTS 20.04 Jun 8 '20 at 5:56
  • 15
    I had the same issue as @K.-MichaelAye I fixed by installing sudo apt install exfat-utils exfat-fuse Jul 3 '20 at 18:29
  • 1
    @ffffranklin you should add this as answer because it is the correct solution and without it Ubuntu disks app also doesn't work. Thank you!
    – Max
    Feb 4 at 9:19
  • 1
    It is the perfect solution till in 2021 Jul 11 at 11:01
15

I have the same problem, I didn't understand why it work anymore.


Now am using KDE Partition Manager. It's like GParted but it supports exFAT (still).

enter image description here

enter image description here

Home Page Link: https://www.kde.org/applications/system/kdepartitionmanager/

GitHub Page Link: https://github.com/KDE/partitionmanager

6
  • 1
    Fair, but KPM requires a lot of heavy dependencies by being KDE software. gnome-disks being gnome software similar to GParted is closer in terms of dependencies Feb 15 '18 at 23:44
  • 2
    Yeah, true. It may be useful for people using KDE based desktop distro that don't came with KPM installed. And thinking about it, gnome based software comes with heavy dependencies too when you use desktop like XFCE.
    – Asme Just
    Feb 16 '18 at 6:23
  • That's correct, but if you already have gparted installed then those dependencies are already there. Feb 16 '18 at 6:35
  • Yeah, that's true. Just like I already had KDE based "apps" installed, So it didn't pull much dependencies either. I love Disks but just for viewing my disks states, I don't have a good experience with it though when it comes to formating unlike Gparted/KPM.
    – Asme Just
    Feb 16 '18 at 19:43
  • In case Disks gives error, use Gparted first to format to fat32 for example, and then proceed as above for exFAT. OR, for a stick or other drive with one single partition, use Disk to select the drive in the left panel but then, instead of the gear button, go to the top right button and select "Format disk" and then "No partitioning (empty)", and then proceed as above.
    – cipricus
    Mar 3 '20 at 14:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.