2

My NVIDIA GPU specs

These are my specs for NVIDIA GPU. I have tried installing CUDA 9.1, but it says "Your device is too old for CUDA version". I have tried installing lower CUDA version, then importing theano says "No CUDA device available".

3

2 Answers 2

2

Your Geforce 820M GPU has a CUDA capability of 2.1 (see Intel geforce gpu list This capability is too low for CUDA 9.0+, but does support CUDA 8.0. Try installing that CUDA version. The Nvidia cudnn has its own set of requirements: on link cuDNN installation Guide First 2.1 requirements bullet:

2.1 *  A GPU of compute capability 3.0 or higher. To understand the compute capability of the GPU on your system, see: CUDA GPUs. Also see the cuDNN Support Matrix.

So your 820M GPU of capability 2.1 is not sufficient to run even the oldest cuDNN offered (See the cuDNN Support Matrix in the above link for details). That prevents anything depending upon cuDNN from running too (like TensorFlow or Therano?).

1

The GPU does not support CUDA.

There are two main variables involved here: the GPU architecture and the driver version. Looking at the error message, it could be the problem with the GPU architecture. Your GPU may have been manufactured using older architecture that does not support CUDA or does not have CUDA cores.

With regards to the GPU architecture, in one part of the online documentation (ref: https://github.com/NVIDIA/nvidia-docker/wiki/Installation-(version-2.0)#prerequisites ), NVIDIA specify that they support the GPUs with architecture newer than Fermi. While this may not immediately translate into minimum version for CUDA, this may hint that the minimum GPU versions supported will be those with Kepler architecture.

The list of NVIDIA graphics card models built with Kepler architecture or newer that should -in theory- support CUDA in this article: http://tech.amikelive.com/node-685/list-of-nvidia-desktop-graphics-card-models-for-building-deep-learning-ai-system/

Looking at the GPU information provided, the graphics card model is GeForce 820M. The GPU code name for this model is GF117. This model is built with Fermi architecture. So, it can be expected that the GPU does not support CUDA.

1
  • I'd like to add some more explanation to prevent confusion on your side. If you look at CUDA capability only, it will be incorrect to say that your GPU does not support CUDA. However, as I understood, the focus is to evaluate the GPU against deep learning use. Like other deep learning frameworks, Theano harnesses cuDNN library. The library will only run if the CUDA capability is bigger than 2.1 (Kepler architecture or newer). It is more practical to notify user that there is no CUDA device other than saying there is a CUDA device but it is too primitive to perform deep learning tasks.
    – Mike
    Mar 30, 2018 at 2:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.