1

I have just installed Gimp 2.8.22 Ubuntu 17.10. The problem is when I have already Gimp opened and want to open another image. I go to Open With Other Application and select Gimp, always new instance of Gimp is starting. And I am not even able to drag new file to Gimp. On my other computer once I have Gimp opened and every other file is opened in the same instance on new tab.

I have tried to uninstall Gimp (and even purge), I have tried installing it using Snap or Ubuntu Software center but with the same results.

EDIT: I am using Single window mode and have just found out there is an area where dropping works (just above tools on the left side of the program) so that part about drag-n-drop not working might be a feature not a bug. But the other problem still remains. I am at least able to work around that using mouse. Still would be nice if somebody will have a suggestion how to fix that.

  • is libdbus-glib installed ? – Robert Riedl Jan 24 '18 at 13:21
  • No, it's not. What is it for? – Juraj.Lorinc Jan 24 '18 at 13:29
  • its a part for dbus which GIMP uses. you can install it with sudo apt-get install libdbus-glib-1-2 – Robert Riedl Jan 24 '18 at 13:32
  • I was wrong. It was already installed: libdbus-glib-1-2 is already the newest version (0.108-2). – Juraj.Lorinc Jan 24 '18 at 13:37
  • okay, you can try to remove your gimp settings with rm -rf ~/.gimp-2.8 (these are kept, even with purge) – Robert Riedl Jan 24 '18 at 13:45
1

Installing GIMP the old school way (using terminal) solved the issue. My guess would be that SNAP and Ubuntu Software center are using different (corrupted/buggy?) version of gimp (2.8.22) but using terminal version 2.8.20 was installed.

  • 1
    My uneducated guess would be that this is due to the virtulization put in place by snaps. Unlike standard packages, which you install via apt-get, snaps are containerized, which may lead to the effects you are seeing. – Witiko Jun 4 '19 at 1:38
  • That makes a lot of sense. You are probably right. – Juraj.Lorinc Jun 4 '19 at 8:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.