I recently purchased a LG a410 notebook, with Nvidia GeForce 310M GPU. When i installed Ubuntu (11.10) my battery used to last about 3 hours. But, since i moved to Gnome3, i noticed that i didnt have the proper graphics driver installed. So, i installed the Nvidia drivers, and everything, including 3d works perfect. The problem is: my battery now lasts only for less than 1 hour. I have read on some forums that Nvidia Drivers are known to consume more battery power. Since my GPU does not seem to have the "optimus" technology, there is no use to try the "bumblebee project". I had the idea to add to grub the option of loading OR NOT the nvidia graphics. This way, when i wanted to save battery, i would boot into the "no nvidia mode". But i have had no success on disabling the Nvidia drivers. I have tried to add it to the /etc/modprobe.d/blacklist.conf as "blacklist nvidia", "blacklist nvidia-common", and "blacklist nvidiabl" but nothing seems to work.

Is there a way i can choose between booting WITH or WITHOUT the nvidia drivers??

Obs: changing the xorg.conf file to Driver "nv" or Driver "intel" does not work (x does not start)


Have a look at Choose at GRUB menu whether NVidia driver should be used for creating a boot option to stop the nvidia driver from being loaded.

nv is a very old opensource driver, superseded by the nouveau driver. That's why setting it does not work for recent hardware.

After blacklisting modules in /etc/modprobe.d you need to run sudo update-initramfs -u to get the blacklist during boot.

  • i dont have the /etc/grub.d/10_linux that the link proposes. i have created it, and added the option modprobe.blacklist=nvidia-current – yurividal Jan 30 '12 at 18:10
  • no success... editing the 10_linux file did not seem to work. after "update-grub" was made, still no boot menu option was generated. Also, on reboot, i tryed to manualy add the command to grub but modprobe.blacklist=nvidia or modprobe.blacklist=nvidia-current did not seem to disable nvidia. – yurividal Jan 30 '12 at 18:17
  • Changing the xorg.conf "Driver" section to "nouveau" also makes x not start – yurividal Jan 30 '12 at 18:20
  • I also blacklisted the 'nvidia' and 'nvidiabl' modules in '/etc/modprobe.d/blacklist.conf', and ran sudo 'update-initramfs -u' but the nvidia is STILL loading! what am i doing wrong? – yurividal Jan 30 '12 at 18:26
  • Try blacklist nvidia-current instead of blacklist nvidia. The module name is nvidia-current because the file is named nvidia-current.so. The driver name is nvidia. – Lekensteyn Jan 30 '12 at 20:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.