3

After updating Firefox this morning to 58, it fails to play any sounds (eg. YouTube plays without sound or Google Calendar events sounds). With the as of yesterday most recent version (57.0.4?), everything worked fine. I now get the message

To play audio, you may need to install the required PulseAudio software. [Learn how]

The link there isn't of any help, as it just suggests to make sure that PulseAudio (which is required from version 52) is correctly installed. As I said, it worked fine with version 57, and I can play sounds with PulseAudio like this:

paplay /usr/share/sounds/freedesktop/stereo/message.oga

Any suggestions?

I'm running Ubuntu 17.10 (GNU/Linux 4.13.0-31-generic x86_64) with xmonad, no flash installed and the only things that updated since yesterday were Firefox and keybase.

4
  • 2
    I don't think it's broken in general (just found one other report of this issue) and don't accept downgrading as the answer. Please stay on topic.
    – iGEL
    Jan 24 '18 at 14:01
  • 2
    @N0rbert I don't think they broke PulseAudio. But I'm with you on the rest, I am typing this on Firefox ESR... Jan 24 '18 at 14:19
  • I'm sorry, but it's unclear (at least to me) what you are asking. What particular type of audio are you attempting to play in the browser that results in that error? I can't reproduce this problem with Firefox 58 under 14.04 LTS nor 16.04 LTS. You say that the link provided was of no help. Did you check for newly unsupported plugins do to the NPAPI support drop?
    – Elder Geek
    Jan 24 '18 at 21:08
  • I've updated the question, but was able to resolve the issue thanks to Monsieur2000's answer afterwards.
    – iGEL
    Jan 25 '18 at 8:35
3

Install the ubuntu-restricted-extras package.

I had the same issue this morning ant it worked for me. It worked for OP too but my answer was deleted.

1
  • unfortunately did not work for me on 14.04
    – Felix
    Jan 31 '18 at 17:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.