2

I just upgraded to Ubuntu Gnome 17.10 after 17.04 went out of support.

After the reboot finalizing the upgrade the Alt+Tab and Alt+Super stopped working.

However, the "Switch Application Windows" Hotkey keeps working, and, if I keep the switcher open by holding down Alt, I can then switch between Applications using Tab.

I already tried resetting those settings and setting the shortcuts using the terminal:

gsettings set org.gnome.desktop.wm.keybindings switch-applications "[]"
gsettings set org.gnome.desktop.wm.keybindings switch-applications-backward "[]"
gsettings set org.gnome.desktop.wm.keybindings switch-windows "['<Alt>Tab', '<Super>Tab']"
gsettings set org.gnome.desktop.wm.keybindings switch-windows-backward  "['<Alt><Shift>Tab', '<Super><Shift>Tab']"

I also switched these around a bit to experiment but couldn't get it to work.

But as of now this is pretty annoying.

How can I fix this?

2
  • Did you check in Preferences -> devices -> keyboard ? – Robert Riedl Jan 24 '18 at 13:25
  • Yes. Whatever I put in there doesn't change the behavior, also no errors related in syslog. – FatalMerlin Jan 25 '18 at 9:29
3

Update:

You can try reloading Gnome via ALT-F2, pressing R and then Enter.

Thanks to Rob Hendricks for this hint.


Original Answer

Interestingly, after issuing the above commands, a reboot fixed it, when reloading the desktop environment didn't.

So for anyone encountering this, set your preferred settings using:

gsettings set org.gnome.desktop.wm.keybindings switch-applications "[]"
gsettings set org.gnome.desktop.wm.keybindings switch-applications-backward "[]"
gsettings set org.gnome.desktop.wm.keybindings switch-windows "['<Alt>Tab', '<Super>Tab']"
gsettings set org.gnome.desktop.wm.keybindings switch-windows-backward  "['<Alt><Shift>Tab', '<Super><Shift>Tab']"

And reboot.

1

The above answer by FatalMerlin worked great. You can also do an ‘alt-f2’ followed by ‘r’ and enter to restart gnome without the reboot...

2
  • Thanks Rob! I'll add that to my answer, if you don't mind :) Also welcome to the StackExchange community! – FatalMerlin Jan 21 '20 at 13:59
  • 1
    Please do :) Been here for a while :) You guys are usually so great that I don't need to add ;) – Rob Hendricks Jan 24 '20 at 5:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.