2

When typing code like \( or \begin{equation} TexStudio is hijacking my document inserting closing \) and adding red boxes its expecting me to type inside of to somehow make go away, and it's slowing me down and interfering with what I wish to type. How do I disable this "helpful" feature?

4

On the top bar, click Options > Configure TeXstudio. Then select Show Advanced Options in the lower left. Then select Adv Editor in the left pane. Then unselect Auto Completion Parentheses.

enter image description here

EDIT:

I believe that you are looking to turn off the Auto Completer which puts in the words. In the left pane, click on Completion. Then unselect Automatically start completer when typing LaTeX-Commands.

enter image description here

Hope this helps!

  • Thank you. What does unchecking "Overwrite [...] Placeholder" accomplish? The expected behavior of typing over the outlined braces inserted by TexStudio did not change. Additionally, \begin{equation} etc. still inserts additional text and I don't see the option to disable it here, but maybe this feature is more acceptable ... It would be good if you would add how to disable this feature as well. – DBinJP Jan 24 '18 at 7:52
  • @DBinJP Added in answer for disabling the completer, which is what I think you are looking for. – Terrance Jan 24 '18 at 15:54
  • The edit is absolutely what I was looking for. Now the editor doesn't bog down my typing and freeze up as it searches for completions. Just writing something as simple as $1 \leq i \leq n$ makes it freeze up and query commands that complete "\l". Ridiculous. – Joshua Detwiler Apr 8 '19 at 5:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.