1

My desktop has a built-in speaker inside the tower, and it's connected to my monitor via HDMI. It's really annoying that the system defaults the speaker to the built-in one and I have to manually change the Sound settings. Is there any way to force HDMI as default device or just disable the built-in?

1

To set default for pulseaudio playback

Use command:

pactl list sinks | grep Name

to get Pulseaudio names of playback sinks

Use the name of your HDMI sink in this command to set it as default:

pacmd set-default-sink <Name>

To check Pulseaudio default sink setting:

cat ~/.config/pulse/*default-sink
| improve this answer | |
  • I set default sink to the hdmi one, however when I boot up today it still falls back to built in analog audio. Thanks – cxwf14 Jan 25 '18 at 2:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.