I seem to be having an issue with sound at the moment, where pulseaudio will only work if I run "sudo pulseaudio --system" after I've killed it. It seems to hang on startup, and I have to run "sudo kill -9 [number of process detected by 'sudo lsof | grep /dev/snd']" before I can run pulseaudio in system mode.

Is there a way to get pulseaudio's config reset somehow to stop it hanging? Or at least work out why pulse seems to hang when not in system mode?


Have you tried looking at the logs? There are a few different log level settings.

Check the man page (http://linux.die.net/man/1/pulseaudio) for information on how to set it. If you can work out at which point it's hanging, then you might be able to see if there's perhaps a permissions issue on a file it's trying to access.

Generally if something works as root, but doesn't as a user, it's guaranteed to be a permissions thing...

Hope that's helped!

Edit: Just re-read your question - spotted that it's not just a root thing, but still, the first step is to look in the log files...

  • I'll give that a shot now, and see what happens. Thanks for your answer. – hazrpg Jan 30 '12 at 14:30
  • Okay so I tried the following: pulseaudio --start -vvvvv and I get this back I: [pulseaudio] main.c: Daemon startup successful. I then tried to load up paman, and it says "connection refused". Nothing can seem to connect to it either. – hazrpg Jan 30 '12 at 14:38
  • Ok, probably worth looking for what the connection is refused to. If you're feeling brave, try using strace on paman, and look through for incidences of "ECONNREFUSED". There may be just one, there may be many. Also, try it when you've run pulseaudio in system mode too, to see the difference in the output. I've got one more thing for you to do as well: Check the contents of /etc/init.d/pulseaudio. It's just a BASH script, but it may contain why your machine isn't doing its proper job on startup. I've looked in mine, and it seems to have references to --system in there... – n00b Jan 30 '12 at 15:08
  • Well /etc/init.d/pulseaudio sounds similar to yours: paste.ubuntu.com/822641. As for running strace... once I hit connect, I can't seem to figure out the incidence of ECONNREFUSED (doesn't seem to be any) however I did notice that it was reporting a file was missing at "/home/hazrpg/.pulse/46b30d6cfeaab1f49f0f1a9d00000011-runtime/native". Following to that directoy leading up to "native", I noticed only one file that was called "pid" only. – hazrpg Jan 30 '12 at 15:19
  • And how does that compare to if you run it in system mode? – n00b Jan 30 '12 at 15:23

Suggestion: If you want to keep features of system-wide mode, you may try to replace 'system.pa' with 'default.pa' config files in /etc/pulse/ with:

sudo mv /etc/pulse/default.pa default.old.pa
sudo cp /etc/pulse/system.pa default.pa

It might need a reboot.

  • Is that really recommended? Wouldn't it make more sense to figure out what's wrong with the current default.pa file instead of using the system.pa which isn't recommended for regular use. – hazrpg Feb 12 '12 at 18:59
  • @hazrpg, No it's not recommended and can cause some recoverable problems, so it's just a suggestion for the moment. I believe it's some module that doesn't work properly or even load at all, but it's very hard to investigate which one. – ashams Feb 13 '12 at 12:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.