0

Specifically: I think I need the terminal to open and have './vert/vertcoin-qt' entered into the Terminal for the program to start.

I have a crypto coin wallet I'd like to open up at startup.
I can start up the wallet manually with no issue by opening a Terminal window and typing...

./vert/vertcoin-qt

I tried putting the code below into a file called 'wallet.sh',

#!/bin/bash
gnome-terminal -e
./vert/vertcoin-qt

I gave the .sh file permissions with...

chmod o+r wallet.sh

Then I put the path to the wallet.sh file in the 'Startup Applications' launcher.
When I do a restart I get the 'loading' screen for the wallet but also a message that says...
Cannot obtain a lock on the data directory /home/eagle/.vertcoin. Vertcoin Core is probably already running.

After the computer has started up like this nothing I do starts the wallet unless I disable the startup task and do a restart.

I've tried launching just the wallet's vertcoin-qt program from the Startup Applications program with no results.

2

Scripts should be called with the full path name to the file as starting with ./vert/vertcoin-qt would have to be in the path that you are in. However, the system doesn't necessarily start in the same folder as you, so giving it the full path name will help it launch from any location. Then add exec $SHELL to keep the terminal open after the script runs.

#!/bin/bash
gnome-terminal -x bash -c "/full/path/to/vert/vertcoin-qt; exec $SHELL"

Make sure that you change /full/path/to to the actual path to where the script is.

Hope this helps!

  • It got the terminal on the screen. So that will probably help me with something I need to do next, but getting the wallet to start gives the same error pictured in the OP i.stack.imgur.com/Ys4mv.png --- from that error it looks like it's trying to start it but something stops it. The program doesn't start like normal programs. I don't even know what to call the state of it. Meaning the making of it was a little half baked. – Ant Jan 22 '18 at 23:55
  • @Ant What does the command ps -ef | grep virtcoin-qt return? It might be starting virtcoin-qt in your Settings > Session and Startup. – Terrance Jan 22 '18 at 23:58
  • 'me 3171 3092 0 19:00 pts/2 00:00:00 grep --color=auto vertcoin-qt' That's what it returns. I'm out of my depth here. I added to the OP at the top that this program doesn't seem to be a normal, fully formed program with a GUI icon to click on to start. It always involves a launch in Terminal so it seems to be more bare bones than the average. – Ant Jan 23 '18 at 0:05
  • @Ant That is so weird. Does the application makers have support? – Terrance Jan 23 '18 at 0:28
  • I don't think so. I vaguely remember scouring the internet and trying to get it to work manually with multiple attempts when I set it up to mine almost a year ago. It's as if I need a bot program to type the commands into Terminal to get it to run at startup. I changed the script type and program that opens it a few times. That error returns permission issues with other Ubuntu programs but I couldn't parallel the solution. – Ant Jan 23 '18 at 1:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.