I'd like to turn off the animation (windows zoom back) effect when the activities overview is activated because it really gets slow and laggy with a lot of open windows.

Is there ANY way to do this, as internet search only lead me to the "Disable Window Animations Extension" which obviously only affects window animations but not the animation of the overview.

In Gnome 3.8, just do this command to disable all animations:

gsettings set org.gnome.desktop.interface enable-animations false

To rollback:

gsettings set org.gnome.desktop.interface enable-animations true

The accepted answer does not disable animations, but only reduces the animation time to almost zero. This means the animation will still be rendered - you're just not able to recognize them.

Maxwell's answer really disables animations, but on my system (Ubuntu 14.04) the animations are enabled again after a reboot. However, there is a workaround for this problem.

Long story short, you can disable animations with these two commands:

gsettings set org.gnome.settings-daemon.plugins.remote-display active false
gsettings set org.gnome.desktop.interface enable-animations false

Edit the following file using root access rights:

sudo gedit /usr/share/gnome-shell/js/ui/overview.js

Change the animation_time to 0.001, around line 30

const ANIMATION_TIME = 0.001;

This should do what you asked for. Besides, there are many other parameters that you could change to speed up Gnome Shell in the other files of the ui directory.

Press Alt+F2 and type "r" or "restart" for the changes to take effect.

Note, future updates to Gnome may overwrite your changes.

Fast forward from 2012 to 2018, since a few years, Gnome Tweaks exposes the setting to turn all animations in Gnome Shell off: Turn "Animations" off on the "Appearance" tab.

The command line method provided by Maxwel Leite is still valid:

gsettings set org.gnome.desktop.interface enable-animations false

To reset to default:

gsettings reset org.gnome.desktop.interface enable-animations

Check out:

System -> Preferences -> Appearance

Then choose the Visual Effects tab.

Change the radio button to 'None' and close.

  • This is interesting. I am using Gnome 3.3 Shell. In my Appearance settings, there is no Visual Effects tab. Only Backgrounds tab is available there! Is something missing?? – deshmukh Mar 22 '12 at 4:09

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.