0

About 4-5 days ago, some updates showed up, but I had the router off. I - not knowing that - clicked on "Install". The update manager showed me "Downloading updates failed. Check your internet connection". So, I did not install the updates.

However, 2 days ago, with the router on, I clicked on "Install". It downloaded some packages, but others failed. And with those packages, the whole download process failed. I tried again a few times, also yesterday, but; the same result.

If you wonder, apt works perfectly - I can install, remove & purge packages normally.

Probably I have to reinstall update-manager because of corruption. But, if the issue is more complex, I am free to suggestions. I also want to install the new Linux kernel (linux-4.4.0-111.134) in order to avoid the Spectre and Meltdown vulnerabilities.

Can anyone please help me?

  • Insufficient data: Please edit your question to include the complete output of sudo apt-get update and sudo apt-get upgrade. Please stick to one question per thread - the Spectre/Meltdown questions have been answered many times, so 'Search' is your friend. – user535733 Jan 22 '18 at 17:35
  • 1
    @karel I reinstalled update-manager today and it worked perfectly! Thanks by the way for commenting. – Bajiru Jan 23 '18 at 9:30
0

Reinstallation of Update Manager worked

I reinstalled update-manager today using sudo apt install --reinstall update-manager and it worked! It also installed some other updates that were available.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.