0

Preamble:

  • Linux newbie for only two days. Adept at Device Manager and devcon.exe under Windows®. Don’t know anything about Linux hardware architecture.

Environment (for details see pastebin):

  • Ubuntu 16.04 LTS, fresh install
  • Audio device 1 (dev1 below): Realtek® ALC887 HD Audio Codec, Intel B75 chipset, MSI B75MA-P45 (MSI-7798) board
  • Audio device 2 (dev2 below): Audio-gd® USB DAC   NFB-2015
  • extra audio pkg installed: alsa-tools, alsa-tools-gui, gnome-alsamixer

Problem Description:

  • All attempts at retasking audio jack pins using sudo hdajackretask of the alsa-tools-gui FAILED:
    • The GUI will report an error message (see below);
    • Sound output will break immediately upon the failure.
  • Audio output on dev1 does NOT work after these attempts:
    • Ubuntu sound mixer shows "Dummy Output" instead of the correct dev1 output pin names;
    • Dev2 plays sound normally.
    • Rebooting or on-off the machine does NOT solve the issue.

Steps to Reproduce:

sudo apt install alsa-tools-gui  
sudo hdajackretask  
Now, Read doc of hdajackretask  
Do retasking according to the docs (e.g. setting Pink Mic Front to Headphone)  
The program throws the following error:  
    tee: /sys/class/sound/hwC0D0/reconfig: Device or resource busy  
It also gives something funny in StdOut:  
    0x11 0x411111f0
    0x12 0x411111f0
    0x14 0x01014010
    0x15 0x411111f0
    0x16 0x411111f0
    0x17 0x411111f0
    0x18 0x01a19c30
    0x19 0x02a19c40
    0x1a 0x0181343f
    0x1b 0x02214c20
    0x1c 0x411111f0
    0x1d 0x4005c603
    0x1e 0x411111f0
    0x1f 0x411111f0
    1  

Now if you try with the optional switches in the GUI, the error continues. The "boot override" function has no effect either.
Also, the system sound mixer no longer shows the proper output pin names. "Dummy Output" appeared. From now on, the system has no sound.

Expectations from answers:

  1. Provide measures to make Ubuntu sing again.
    • 1.1 OS Re-installation or direct tampering with OS kernel is unfavoured though acceptable.
  2. Provide solutions to make audio jack retasking possible. I need them for double headphone output, multi-channel output etc.
  3. Provide a terse explanation of what exactly went wrong with hdajackretask.
  4. Provide further sources of reference so that I can learn about how to properly configure hardware devices in Ubuntu Linux.

Additional Troubleshooting Information:

  • alsa-info.sh see pastebin
  • dev1 and dev2 are both identifiable using either sudo lshw or sudo lshw-gtk
  • alsamixer correctly shows the audio devices
  • gnome-alsamixer loads with the following errors:
    ** (gnome-alsamixer:3161): WARNING **: gam_toggle_get_state (). No idea what to do for mixer element "Auto-Mute Mode"!
    ** (gnome-alsamixer:3161): WARNING **: gam_toggle_get_state (). No idea what to do for mixer element "Channel Mode"!
    ** (gnome-alsamixer:3161): WARNING **: gam_toggle_get_state (). No idea what to do for mixer element "Input Source"!
    ** (gnome-alsamixer:3161): WARNING **: gam_toggle_get_state (). No idea what to do for mixer element "Input Source"!
    ** (gnome-alsamixer:3161): WARNING **: gam_toggle_get_state (). No idea what to do for mixer element "Loopback Mixing"!
  • pacmd list cards:
    0 card(s) available.
    0 sink input(s) available.
    0 source output(s) available.
    0 cache entrie(s) available.
  • speaker-test:
    speaker-test -Ddefault -c2 no sound
    speaker-test -Dpulse -c2 no sound
    speaker-test -Dsysdefault -c2 ok
    speaker-test -Dfront:PCH -c2 ok
    speaker-test -Dhw:PCH -c2 ok
    speaker-test -Dplughw:PCH -c2 ok
1

Since I am all new to Linux the method I propose may not be the most efficient one, fyi.

The strange behaviour described in the question is due to alsa being misconfigured either during system setup or upgrade. Besides, if hdajackretest is run with sudo from the very beginning the jack retasking configuration will also fail because hdajackretest cannot properly read “user profile data” as root.
Reinstallation of the entire alsa framework worked for me. Since the system audio service (PulseAudio) works hand-in-hand with alsa reinstallation of PulseAudio is also recommended.

Using the reinstallation command from a package manager e.g. Synaptic won’t work because such reinstallation does not clear up config files created by the application. You must first purge, then reinstall, finally reconfigure. I know this sounds like Windows troubleshooting, but with Ubuntu becoming more and more GUI-dependent there seems to be good reason to think in Windows way on Ubuntu, too.


Detailed steps:

  1. Install aptitude. This is required.
  2. Learn how to use aptitude; there is no mouse support, by the way.
  3. Configure your computer network to automatically connect to the Internet via a cable connection with DHCP enabled and no manual DNS specified. Otherwise you’ll suffer later.
  4. Reboot into recovery mode. Enable network to load more device drivers. Enter root “command prompt”.
  5. Use aptitude to purge uninstall PulseAudio and alsa. Specifically, purge any package containing the pattern “pulseaudio” or “alsa”. You must take a note of all the dependant packages uninstalled together with the two, which includes the Ubuntu desktop shell (so that you won’t have GUI now). Pay attention to version number.
  6. Restart and enter the root command prompt again. Use ping to test network connection. If you don’t have network access, search online with another computer on how to configure network in Linux from the command line.
  7. Use aptitude to install PulseAudio and alsa anew.
  8. Use aptitude to install the dependant packages anew also.
  9. Reboot into normal mode. Your audio configurations are all lost and restored to a fresh-install state.
  10. Run hdajackretask w/o sudo prefix, and do jack retasking config as you like. When prompted for sudo privileges do it.
  11. You should be having functional audio jack retasking now.

If you tried but still things don’t work, I suggest you go back to Windows or Mac for multimedia stuff. Sometimes things just don’t work in Linux as in other OSes and Linux enthusiasts may simply think they don’t need so either.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.