0

I tried install the nvdia driver for ubuntu 17.10, but it was a failure the display was totally black. So I purged the Nvidia drivers and returned back to generic display driver but unfortunately it was not completely reverted back, which causing the following issues

  1. Never resume back from suspend mode
  2. Display resolution gone back to 1280x800
  3. No brightness control
  4. No night mode
  5. Gama error. etc... My display card is 02:00.0 VGA compatible controller [0300]: NVIDIA Corporation C79 [GeForce 9400M] [10de:0863] (rev b1) The xrandr gives the following error

    xrandr: Failed to get size of gamma for output default Screen 0: minimum 1280 x 800, current 1280 x 800, maximum 1280 x 800 default connected primary 1280x800+0+0 0mm x 0mm 1280x800 76.00* Lightdm service status is

    ● lightdm.service - Light Display Manager Loaded: loaded (/lib/systemd/system/lightdm.service; enabled; vendor preset: Active: active (running) since Mon 2018-01-22 18:44:15 IST; 24min ago Docs: man:lightdm(1) Process: 14037 ExecStartPre=/bin/sh -c [ "$(basename $(cat /etc/X11/default-di Main PID: 14048 (lightdm) Tasks: 7 (limit: 4915) Memory: 33.4M CPU: 2min 56.014s CGroup: /system.slice/lightdm.service ├─14048 /usr/sbin/lightdm └─14069 /usr/lib/xorg/Xorg -core :0 -seat seat0 -auth /var/run/lightd

Jan 22 18:44:16 shameerariff-MacBook lightdm[14083]: PAM unable to dlopen(pam_kw Jan 22 18:44:16 shameerariff-MacBook lightdm[14083]: PAM adding faulty module: p Jan 22 18:44:16 shameerariff-MacBook lightdm[14083]: pam_unix(lightdm-greeter:se Jan 22 18:44:20 shameerariff-MacBook lightdm[14148]: PAM unable to dlopen(pam_kw Jan 22 18:44:20 shameerariff-MacBook lightdm[14148]: PAM adding faulty module: p Jan 22 18:44:20 shameerariff-MacBook lightdm[14148]: PAM unable to dlopen(pam_kw Jan 22 18:44:20 shameerariff-MacBook lightdm[14148]: PAM adding faulty module: p Jan 22 18:44:20 shameerariff-MacBook lightdm[14148]: pam_succeed_if(lightdm:auth Jan 22 18:44:58 shameerariff-MacBook lightdm[14048]: g_object_unref: assertion ' Jan 22 18:44:58 shameerariff-MacBook lightdm[14148]: pam_unix(lightdm:session):

It seems weired to me. I tried restoring using the Wiki Ubuntu but still all my efforts are failed.

  • GeForce 9400M is legacy hardware currently supported only by Nvidia 340 driver version. I suggest you install that one properly. – user692175 Jan 22 '18 at 13:51
  • I tried installing from NVIDIA official website and the file name was NVIDIA-Linux-x86_64-340.104.run as well as from the ubuntu repository, but both failed. – Shameerariff Jan 22 '18 at 14:08
  • If you used the Nvidia binary you need to run it again with the uninstall option otherwise the leftovers will prevent any further experiments. Likewise, you need to purge the drivers installed with APT in order to start over. Had you from the beginning installed properly - opening Additional drivers, selecting and applying - nothing of this would be happening. – user692175 Jan 22 '18 at 14:32
  • now I am getting a new error from nvidia install ie. X server – Shameerariff Jan 22 '18 at 15:42
  • Somehow I managed to install nvidia 340 driver from ubuntu repository and no difference when I run the nvidia-detector it says none. Its surprising me. Probably today was my bad luck – Shameerariff Jan 22 '18 at 16:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.