7

My Ubuntu 16.04 system boots to X.Org failsafe mode (xinit fails). I cannot find out why. The file /var/log/Xorg.0.log contains the following:

/dev/dri/card0: No such file or directory

PS: My system was working fine until I removed 2 kernel images which were not being used (4.4.0-57 and 4.4.0-59). I use 4.4.0-53. The boot process ends with reached target graphical failsafe runlevel fallback and does not go further.

1
  • 5
    please don't edit your title to add [SOLVED]. Your question still shows up as unanswered until you put the answer in the answer section below and accept it (or get an upvote or it) (or someone else provides an answer that is upvoted or accepted). It would be awesome if you could edit to remove the answer from your question and post it below instead
    – Zanna
    Jan 22 '18 at 11:45
7

According to the questioner, user152037, reinstalling the drivers fixed it:

sudo apt-get install --reinstall xserver-xorg-video-intel xserver-xorg-core
sudo dpkg-reconfigure xserver-xorg
1
  • Reinstalling the drivers worked for me on debian as well. Jan 7 '20 at 2:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.