5

After I updated Kubuntu from version Zesty (17.04) to Artful (17.10) krusader suddenly sees office formats (doc, docx, xls, xlsx) as zip archives, where as dolphin sees them correctly. How do I fix it?

My current workaround is to set libreoffice as a zip-opening program in Krusader.

2
  • 1
    Note that docx and xlsx are zip-archives.
    – IQV
    Jan 22, 2018 at 9:09
  • Yeap. Where as rtf is a plain text with a syntax similar to TeX.
    – Adobe
    Jan 22, 2018 at 9:18

2 Answers 2

10

This should be perhaps a comment, but as mentioned here deinstalling WPS solves the problem. It worked for me also. Alternatively (untested):

  • Remove the 3 xml files wps-office-et.xml wps-office-wpp.xml wps-office-wps.xml from /usr/share/mime/packages/
  • sudo update-mime-database /usr/share/mime
  • Assign the .xlsx format to et, the .docx format to wps

Credit to users miku and unsocialwhoyou from mentioned forum.

0

This worked for me:

Select an existing .zip file, right click and edit Properties then on the General Tab click File Type Options to bring up mime like setting for zip files.

Add wildcard *.xpi to the list of extensions alongside *.zip

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.