1

I've installed the util from PPA

sudo add-apt-repository ppa:atareao/atareao
sudo apt-get update
sudo apt-get install touchpad-indicator

In the software preferences I've selected "Disable touchpad on typing" and "Disable touchpad when mouse plugged"

Both don't work.

root@workbee:/home/alex# xinput
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SEM USB Keyboard                          id=9    [slave  pointer  (2)]
⎜   ↳ Synaptics TM3336-001                      id=12   [slave  pointer  (2)]
⎜   ↳ SEMICCHIP Usb Mouse                       id=10   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Video Bus                                 id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ SEM USB Keyboard                          id=8    [slave  keyboard (3)]
    ↳ EasyCamera: EasyCamera                    id=11   [slave  keyboard (3)]
    ↳ Ideapad extra buttons                     id=13   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=14   [slave  keyboard (3)]

Ubuntu 16.04 x64

Lenovo IdeaPad 320-15IKB

UPDATE

I've remembered an important detail.

Sometimes ago (a week or two) I installed the same (I think) touchpad indicator on some other system. Unfortunately, I don't remember how I installed it, and what system exactly was, but I remember that it had a very useful option in its settings, something like "Input Source" or "Input Method". It was a dropdown menu with 3 options. By switching between options I was able to make Touchpad Indicator able to manage touchpad status. I want to have that settings again.

  • I would run it by the author of the software atareao-team – stumblebee Jan 22 '18 at 8:13
  • What do you mean? To log a bug there? – gumkins Jan 22 '18 at 8:23
  • I used Touchpad-indicator with some previous releases of Lubuntu, but I have problems with some of the newer versions. Maybe some features you want have disappeared in the version of Touchpad-indicator for Ubuntu 16.04. I agree with @stumblebee, that you should ask the developer for help directly (via a bug report or more directly, if you can establish a dialogue). – sudodus Jan 22 '18 at 10:02
  • What does uname -r report for kernel version? – WinEunuuchs2Unix Jan 22 '18 at 13:22
  • 4.13.0-26-generic – gumkins Jan 22 '18 at 13:27
0

Try the following synclient commands,

From man synaptics

   Option "TouchpadOff" "integer"
          Switch off the touchpad.  Valid values are:

          0   Touchpad is enabled
          1   Touchpad is switched off (physical clicks still work)
          2   Only tapping and scrolling is switched off
          When  the  touchpad  is  switched off, button events caused by a
          physical button press are still interpreted. On a ClickPad, this
          includes  software-emulated  middle and right buttons as defined
          by the SoftButtonAreas setting.

   Property: "Synaptics Off"

Try the following commands to turn the touchpad on and off

synclient touchpadoff=0
synclient touchpadoff=1

They work for me for example in Lubuntu and Xubuntu. If they work for you, create aliases for them to make things convenient.

There is a GUI alternative in standard Ubuntu 16.04 LTS:

  • Click on the icon with a cog wheel and a wrench
  • Select Mouse and Touchpad
  • Click on the switch at the right side of the window to toggle on/off.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.