This question already has an answer here:

After a recent update to Ubuntu Gnome 16.04 LTS my trackpad's movements have been inconsistent. I turned the acceleration to zero through the xset command, but the problem still occurs.

I duel booted windows and tested the trackpad on their with no issue, so I assume this isn't hardware related.


  • Synaptics Touchpad
  • Ubuntu 18.04

marked as duplicate by muru, karel, Elder Geek, Eric Carvalho, Community Feb 10 '18 at 0:46

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • What does uname -r display when you type it in the terminal? – WinEunuuchs2Unix Jan 22 '18 at 4:58
  • 1
    @WinEunuuchs2Unix 4.13.0-30-generic – user785788 Jan 22 '18 at 5:34
  • Sounds related to this 4.13.0-26-generic update problem. Last user with touchpad problem reported success upgrading kernel to 4.14.14-041414-generic just yesterday. – WinEunuuchs2Unix Jan 22 '18 at 11:12
  • @WinEunuuchs2Unix I'm now running 4.14.14-041414-generic but the issue still persists. Any other recommendations? – user785788 Jan 22 '18 at 21:46
  • Check the second answer on the link above. It deals with Ubuntu 17.10 update. Also remove the kernel 4.14.14 so you get back onto regular kernel updates on the 4.13 kernel chain which is supported. Removing kernels is described in the link above.. – WinEunuuchs2Unix Jan 23 '18 at 0:22

I'd the same problem, it could be a driver touchpad issue.

--> Check also Here

In my case, I had a conflict between the old synaptic driver and the new libinput package. This topic helps me : Debian GNOME: touchpad settings missing. Use libinput instead of synaptics

After fresh install of libinput, I ran :

sudo apt-get purge xserver-xorg-input-synaptics

And my touchpad works again