0

I just allowed my system to restart and install a firmware update on a Dell XPS 15 (9560) which went smooth and was successful.

Upon reboot however it shows the following message then boots to (Windows) automatic repair (non-existent; left it in case I want to reinstall windows with the restore image I made). This occurs when the first entry (in the second image) is selected (the default now).

enter image description here

In the boot options this is what I see. No Ubuntu entry as it used to be.

enter image description here

I launched a live USB (seen above) and I can see all (encrypted) partitions still there.

In the bios setup when I click add boot option I can find two relevant directories (Ubuntu and Boot). Under Boot there's only one entry (bootx64.efi).under Ubuntu there are a number of entries (fwupx64.efi, grubx64.efi, grub.cfg, shimx64.efi, mmx64.efi, fbx64.efi)

I've never dealt with similar stuff so your help is appreciated.

My best guess is that grub has been overwritten or corrupted? Or it it related to the secure boot opinion I have? How can I fix it?

0

I solved the problem by adding a boot option n the BIOS setup. I thought it was logical to first try \EFI\Ubuntu\grubx64.efi which worked. I am back in my system. Here is a clearer explanation:

  • Reboot into the BIOS setup
  • Click Add Boot Option
  • Give it a name (e.g. Ubuntu)
  • For File Name, under \EFI\Ubuntu directory select grubx64.efi.
  • Save the settings and exit.
  • You should see the grub soon.

As a precaution, once in my system I ran sudo update-grub and sudo grub-install though both are redundant to each other.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.