0

I have two OS on my notebook. The first one is Ubuntu 12.04 and it is rather OK, but too old and damaged by my unexperienced actions (manual package installations, etc). The second one is Ubuntu 16.04. It was a fresh install (not upgrade) and I have installed many applications and libraries in it.

Suddenly I noticed that Ubuntu 16.04 slows down. Unity becomes choppy, all applications run slowly. It takes place once a while, especially after long period of working. (And especially when my friends, most of which are windows-users, are working with me.)

cpufreq-info says:

cpufrequtils 008: cpufreq-info (C) Dominik Brodowski 2004-2009 Report errors and bugs to cpufreq@vger.kernel.org, please. analyzing CPU 0: driver: acpi-cpufreq CPUs which run at the same hardware frequency: 0 CPUs which need to have their frequency coordinated by software: 0 maximum transition latency: 10.0 us. hardware limits: 800 MHz - 2.30 GHz available frequency steps: 2.30 GHz, 1.80 GHz, 1.60 GHz, 1.40 GHz, 1.20 GHz, 1000 MHz, 800 MHz available cpufreq governors: conservative, ondemand, userspace, powersave, performance, schedutil current policy: frequency should be within 800 MHz and 1.40 GHz. The governor "ondemand" may decide which speed to use within this range. current CPU frequency is 1.41 GHz. cpufreq stats: 2.30 GHz:5,45%, 1.80 GHz:3,30%, 1.60 GHz:2,71%, 1.40 GHz:4,81%, 1.20 GHz:8,84%, 1000 MHz:17,69%, 800 MHz:57,20% (276340) analyzing CPU 1: driver: acpi-cpufreq CPUs which run at the same hardware frequency: 1 CPUs which need to have their frequency coordinated by software: 1 maximum transition latency: 10.0 us. hardware limits: 800 MHz - 2.30 GHz available frequency steps: 2.30 GHz, 1.80 GHz, 1.60 GHz, 1.40 GHz, 1.20 GHz, 1000 MHz, 800 MHz available cpufreq governors: conservative, ondemand, userspace, powersave, performance, schedutil current policy: frequency should be within 800 MHz and 1.40 GHz. The governor "ondemand" may decide which speed to use within this range. current CPU frequency is 1.47 GHz. cpufreq stats: 2.30 GHz:9,57%, 1.80 GHz:3,13%, 1.60 GHz:2,55%, 1.40 GHz:4,67%, 1.20 GHz:8,55%, 1000 MHz:16,73%, 800 MHz:54,80% (256609) analyzing CPU 2: driver: acpi-cpufreq CPUs which run at the same hardware frequency: 2 CPUs which need to have their frequency coordinated by software: 2 maximum transition latency: 10.0 us. hardware limits: 800 MHz - 2.30 GHz available frequency steps: 2.30 GHz, 1.80 GHz, 1.60 GHz, 1.40 GHz, 1.20 GHz, 1000 MHz, 800 MHz available cpufreq governors: conservative, ondemand, userspace, powersave, performance, schedutil current policy: frequency should be within 800 MHz and 1.40 GHz. The governor "ondemand" may decide which speed to use within this range. current CPU frequency is 1.41 GHz. cpufreq stats: 2.30 GHz:8,27%, 1.80 GHz:3,19%, 1.60 GHz:2,57%, 1.40 GHz:4,60%, 1.20 GHz:8,56%, 1000 MHz:16,26%, 800 MHz:56,54% (274971) analyzing CPU 3: driver: acpi-cpufreq CPUs which run at the same hardware frequency: 3 CPUs which need to have their frequency coordinated by software: 3 maximum transition latency: 10.0 us. hardware limits: 800 MHz - 2.30 GHz available frequency steps: 2.30 GHz, 1.80 GHz, 1.60 GHz, 1.40 GHz, 1.20 GHz, 1000 MHz, 800 MHz available cpufreq governors: conservative, ondemand, userspace, powersave, performance, schedutil current policy: frequency should be within 800 MHz and 1.40 GHz. The governor "ondemand" may decide which speed to use within this range. current CPU frequency is 1.34 GHz. cpufreq stats: 2.30 GHz:4,96%, 1.80 GHz:3,40%, 1.60 GHz:3,15%, 1.40 GHz:6,25%, 1.20 GHz:12,28%, 1000 MHz:15,64%, 800 MHz:54,31% (303947) There could be different values instead of 1.40 GHz, even 920 MHz and 800 MHz.

intel_pstate is disabled with grub option.

dmesg | grep temperature says [19065.630210] CPU3: Core temperature above threshold, cpu clock throttled (total events = 2551) [19065.630212] CPU2: Core temperature above threshold, cpu clock throttled (total events = 2551) [19065.630214] CPU1: Package temperature above threshold, cpu clock throttled (total events = 2729) [19065.630216] CPU0: Package temperature above threshold, cpu clock throttled (total events = 2729) [19065.630219] CPU2: Package temperature above threshold, cpu clock throttled (total events = 2729) [19065.630225] CPU3: Package temperature above threshold, cpu clock throttled (total events = 2728) [19065.641347] CPU3: Core temperature/speed normal [19065.641350] CPU2: Core temperature/speed normal [19065.641358] CPU1: Package temperature/speed normal [19065.641361] CPU0: Package temperature/speed normal [19065.641387] CPU2: Package temperature/speed normal [19065.641393] CPU3: Package temperature/speed normal [19783.068723] CPU2: Core temperature above threshold, cpu clock throttled (total events = 2780) [19783.068727] CPU3: Core temperature above threshold, cpu clock throttled (total events = 2780) [19783.068734] CPU1: Package temperature above threshold, cpu clock throttled (total events = 2963) [19783.068738] CPU0: Package temperature above threshold, cpu clock throttled (total events = 2963) [19783.068746] CPU3: Package temperature above threshold, cpu clock throttled (total events = 2962) [19783.068760] CPU2: Package temperature above threshold, cpu clock throttled (total events = 2963) [19783.078851] CPU2: Core temperature/speed normal [19783.078854] CPU3: Core temperature/speed normal [19783.078885] CPU0: Package temperature/speed normal [19783.078888] CPU1: Package temperature/speed normal [19783.078891] CPU3: Package temperature/speed normal [19783.078897] CPU2: Package temperature/speed normal

cat /sys/devices/system/cpu/cpufreq/policy0/bios_limit says 2300000

sensors says ``` coretemp-isa-0000 Adapter: ISA adapter Package id 0: +72.0°C (high = +80.0°C, crit = +85.0°C) Core 0: +72.0°C (high = +80.0°C, crit = +85.0°C) Core 1: +72.0°C (high = +80.0°C, crit = +85.0°C)

acpitz-virtual-0 Adapter: Virtual device temp1: +70.0°C (crit = +120.0°C) temp2: +29.8°C (crit = +120.0°C)

nouveau-pci-0100 Adapter: PCI adapter GPU core: +1.08 V (min = +0.83 V, max = +1.08 V) temp1: +72.0°C (high = +95.0°C, hyst = +3.0°C) (crit = +105.0°C, hyst = +5.0°C) (emerg = +135.0°C, hyst = +5.0°C) ```

/sys/module/processor/parameters/ignore_ppc is manually set to 1

sudo modprobe acpi_cpufreq lsmod | grep acpi_cpufreq says nothing

sudo sh -c "echo 2300000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq" cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq has no effect

uname -a says Linux nicknout 4.13.0-26-generic #29~16.04.2-Ubuntu SMP Tue Jan 9 22:00:44 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Switching governor doesn't matter.

Pluginn off the charger and replugging it back doesn't matter.

Sometimes low performance appears for several seconds, and then max freq restores to 2.3 GHz

0

It was not actually a bug, it was reqular feature to avoid overheatting. Ifi you really want to disable this (that is not recommended), just do:

sudo killall thermald

thermald was introduced in Ubuntu 14.04

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.