1

I wrote this a year ago. Still not solved, so I have re-written it to reflect the current state.

System:
Ubuntu 16.04 LTS, and a Canon Pixma MG5751 multifunction printer/scanner on USB.

Problem:
Printer works perfectly. Scanner is the same USB device but not recognized by sane, but works fine with Canon's scangearmp2. The scanner has worked perfectly with Ubuntu earlier, even using Simple Scan; I have no idea what changed.

Please:
How can I get the scanner working under sane again?

Steps so far:

  1. I have removed and re-added the printer several times.
  2. I have also purged and reinstalled the Canon cnijprinter and scangearmp2 packages in between.
  3. Reading around other very similar questions, I've found that my computer does recognize the device.
    • lsusb|grep Canon provides:
      Bus 001 Device 003: ID 04a9:178e Canon, Inc.
    • sane-find-scanner finds nothing but complains about insufficient permissions.
    • sudo sane-find-scanner|grep Canon finds the device:
      found USB scanner (vendor=0x04a9 [Canon], product=0x178e [MG5700 series]) at libusb:001:003
    • sudo scanimage -L does not find the scanner, and neither does Simple Scan:
No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

I'm out of ideas. Please help! Thank you.


Update based on comments: I've installed the sane-git package and tested: no success. Scangearmp2 works but Simple Scan still doesn't see the scanner. The sane-git page also linked to the latest release version sane-release which I also installed, and that caused a lot of promising lines like Installing new version of config file /etc/sane.d/canon_dr.conf ... - but the result was the same; Scangearmp2 works but Simple Scan still doesn't see the scanner.


Update 20190122:
After an hour of working with apt-get I have now made some progress, but only partially.

  • scanimage -L now finds the scanner, even without sudo:
device `pixma:MG5700_192.168.1.81' is a CANON Canon PIXMA MG5700 Series multi-function peripheral
device `pixma:04A9178E_733AA7' is a CANON Canon PIXMA MG5700 Series multi-function peripheral
  • When I start Simple-Scan, it does not immediately complain about no scanner found. This is good.
  • When I start a scan, it complains: Failed to scan: Error communicating with scanner.
  • In Simple-Scan > Document > Preferences, I see that there are two scanners listed, and the first one is selected. I selected the second choice and tried again = SUCCESS! I guess it doesn't like the network scanner but USB works. I'm happy!
  • and if you type scangearmp2 in a terminal, does that load Canon's programme called ScanGearMP and does it see the device? – pdc Jan 23 '18 at 1:48
  • beyond that; the developers of sane will often recommend installing the latest release of sane from here launchpad.net/~rolfbensch/+archive/ubuntu/sane-git and another useful thing may be to join their mailing list: lists.alioth.debian.org/mailman/listinfo/sane-devel and they may be best able to advise if their newest version does not help – pdc Jan 23 '18 at 2:49
  • I had similar problems with a multifunction Canon device, but it was networked, not USB. It is working well now, everything works except the ADF with sane. I did so much stuff to try and fix it that I have no idea what actually worked. For a long time I used the rolfsbensch ppa; I think that did help, but in 18.04 it isn't required. – Organic Marble Jan 14 at 22:23
1
+100

The sane-pixma library implements a SANE (Scanner Access Now Easy) backend that provides access to Canon PIXMA / i-SENSYS / imageCLASS / imageRUNNER multi-function devices (All-in-one printers) and the Canon CanoScan Flatbed/TPU scanners. The backend implements both the USB interface and network interface (using Canon's BJNP and MFNP proto‐ cols). The network interface supports scanners over IPv4 as well as IPv6 (MFNP over IPv6 is untested).

This backend is required in order to get your scanner to work under sane

While I do not have your scanner and cannot test, it appears that you are missing the libsane-pixma.so library that supports the Canon Pixma MG5700 series for sane. The package that contains it is libsane-dev, is in the repositories and can be installed with the command sudo apt install libsane-dev

You can confirm that you have the file with the command find /usr -name *.so | grep pixma

Sources:

http://www.sane-project.org/man/sane-pixma.5.html

https://packages.ubuntu.com/xenial/libsane-dev

  • I did sudo apt install libsane-dev but I seem to be missing files: ls: cannot access '/usr/local/lib/sane/': No such file or directory -- why don't I have that directory? My /usr/local/lib/ only contains python2.7 and python3.5. – Torben Gundtofte-Bruun Jan 22 at 6:20
  • (Also, I am kicking myself for forgetting I had this question; I haven't paid attention!) – Torben Gundtofte-Bruun Jan 22 at 6:21
  • After an hour of tinkering with apt-get, I have made progress: sudo scanimage -L now finds the scanner! But Simple-Scan doesnt... See details in my question. – Torben Gundtofte-Bruun Jan 22 at 7:48
  • Solved! It works now. I still don't have the path /usr/local/lib/sane/ you mention but I'll grant you the reward anyway :-) – Torben Gundtofte-Bruun Jan 22 at 7:58

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.