• Reinstalling the OS
  • Restarting network-manager using sudo service network-manager restart
  • Adding network controller to black list
  • Removing network controller from black list

After restarting the network manager the wifi makes presence but it says wifi hardware switch blocked.. I tried pressing the keyboard wifi key but it only turned off the bluetooth instead of the wifi.

Am I missing something?


Here is how you could get your Alienware 17 working on Ubuntu:

  1. Connect the machine to Internet using a LAN cable.
  2. Change these after entering BIOS setup
    1. Set boot mode to Legacy
    2. Bring up the priority of the USB drive above hard disk in boot device list.
    3. Save and restart.
  3. Install Ubuntu from a USB stick.
  4. After booting to newly installed Ubuntu –
    1. Install Wifi
      1. Open Terminal
      2. sudo apt-get upgrade
      3. yeah that’s it. Atheros Qualcomm Killer Wifi driver would now be installed.
      4. Restart the system, look for Wifi icon in status bar to verify.
    2. Install NVidia GeForce Graphics card driver
      1. Open Terminal
      2. sudo add-apt-repository ppa:graphics-drivers/ppa
      3. sudo apt-get update
      4. sudo apt-get install nvidia-358 nvidia-settings ( nvidia-358 was the latest version when I installed. Please find the current version from here )
      5. Restart, verify if “GeForce GTX ** ” is shown as the Graphics card in “About This Computer” dialog.
    3. Fix issue with headphones not working –
      1. Open Terminal
      2. alsamixer
      3. Press F6
      4. Select “HDA Intel PCH” card
      5. Press right arrow till the Item shown is “HP/Speaker Auto Detect”
      6. Press M to set it on.
      7. Connect headphones and verify if it works.

Your Linuxed Alienware should now be up with sound, graphics and Wifi and Bluetooth working without issues.


Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.