9

I got an Xbox One S controller as a gift for Christmas and I found out that it can connect to a PC with Bluetooth. It's supposed to work on Windows 10 but it doesn't work on my Ubuntu PC. It shows up as an option in the Bluetooth settings but when I connect to it it just instantly loses connection. How can I use the controller via Bluetooth on my Ubuntu 17.10 PC? I would like to use it for emulators and maybe even Steam games.

12

To solve your problem:

  1. Install sysfsutils

    sudo apt install sysfsutils
    
  2. Edit /etc/sysfs.conf (as admin), add this line at the end of the file:

    /module/bluetooth/parameters/disable_ertm=1
    
  3. Save changes and restart

Reference:

| improve this answer | |
  • It still doesn't connect to the controller. The light on the controller never stops flashing and the PC always disconnects from the controller immediately. – Caden Mitchell Jan 21 '18 at 21:02
  • Okay, this half worked. After trying a few times the controller did finally pair. The problem is that it doesn't show up as a controller in the emulator. Also, I tried running my Blender Game that I made that supports Xbox One controller input and even that didn't recognize my controller. How do I get programs to recognize the controller as a controller? – Caden Mitchell Jan 27 '18 at 0:11
  • Check this link, hope it works. – galoget Jan 27 '18 at 0:52
  • 1
    Thanks. I actually tried doing everything that you said to do in your answer again and now it works 100% correct! Thank you so much! This will be really helpful! – Caden Mitchell Jan 27 '18 at 2:45
  • The solution for arch based distros: "edit /etc/default/grub and add the kernel flag 'bluetooth.disable_ertm=1' to the GRUB_CMDLINE_LINUX line. Then run 'sudo grub-mkconfig -o /boot/grub/grub.cfg' and reboot." After this, you should be able to pair your gamepad. – Adrian Lopez May 3 '18 at 1:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.