Okay I'm really lost on this one. After installing AMD Catalyst driver 12.1 on my laptop, it worked after a few tweaks. I was jumping with joy prematurely because the driver finally worked, only to find out later after a reboot that the proprietary driver went nuts yet again (same with the earlier AMD graphics drivers last year I've tried).

As usual when using fglrx I get a black screen instead of GDM, and if I do manage to get to a desktop I get the error from AMDCCCLE control panel that it cannot initialize because the device or driver is not found (something like that). So going back, Ctrl+Alt+F* keys are useless. After a couple reboots with the same result, I continued to recovery mode and deleted all fglrx related installs. I proceeded to reinstall a few packages as suggested on this page - http://wiki.cchtml.com/index.php/Ubuntu_Natty_Installation_Guide#Removing_Catalyst.2Ffglrx.

Note that I've done this several times without issues but the flgrx drivers. Whenever I reverted I always got everything back to normal. This time is not the same. Keyboard and touchpad are not working. The wireless mouse will work after I plug in the receiver when the boot reaches GDM, or I unplug-plug it. This is not a hardware issue. On Windows 7 and Live Ubuntu all 3 devices work properly without me doing anything.


I am answering my own question in the hopes that this would help others. Note that upgrading to a newer version or changing distro is NEVER a fix to problems like this. However, I cannot have my work laptop not work. So after 3 days of not being able to find a fix for the problem above, I had no choice. Desperate times call for desperate measures.

Found similar situations to my problem here on AskUbuntu but not enough to fix the problem. On IRC #ubuntu, the people were not familiar with the issue, so again, I got no fix. Search about the topic on the Internet didn't improve my situation although I found several leads, it still did not fix the issue.

Hence my only options were to re-install Natty Narwhal from scratch, which I did not want to do in the first place. My second option was to upgrade to Oneiric (using the network upgrade so all my personal data are retained). I did the latter and now my keyboard and wireless mouse is working without a hitch. However, the touchpad was still dead. The weird thing is that the touchpad works on Guest account but not on my regular user account. I created a temporary user to see if it will work, but no, touchpad is still dead in the water.

An answer here fixed the problem: Touchpad not working on Dell XPS L501x

The drawback is that on the next boot, the touchpad will, again, fail to work.

To fix this I placed the commands below in /etc/rc.local

modprobe -r psmouse
modprobe psmouse proto=imps

This works on every boot so far.

If anybody knows how to properly fix this issue please update this post.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.