3

This question already has an answer here:

On Ubuntu 17.10, When try to switch layouts by clicking Super + Space, I get the current window losing focus for a moment, which -usually- make the first letters I try to type missing.

The reason -as I think- is the popup screen appears with Layouts Choices, which get completely visible, if I continued holding the Super key after hitting the Space.

Example: The popup

So, Is there a way to disable that popup ?

Thanks.

marked as duplicate by pomsky gnome-shell Oct 15 '18 at 21:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • your apparent loss of focus may actually be a system halt as the new layout is applied. if this is the case then there is nothing to be done about it but wait a couple seconds. – ravery Jan 20 '18 at 17:17
3

I don't know how to disable that feature, but there may be a workaround.

You can install gnome-tweak-tool and then search for and open Tweaks from the Activities overview. You'll find a GUI for setting an alternative shortcut for input source switching at Keyboard & Mouse -> Additional Layout Options -> Switching to another layout.

AFAIK, that window does not pop up when using such an alternative shortcut.

  • Tried setting Ctrl + Shift as the switching shortcut, the popup not showing anymore, but still getting the focus lost for a moment the same as been happening with the popup ! – code2be Jan 20 '18 at 17:40
  • 2
    @Gunnar Hjalmarsson and code2be, it seems this is a bug – Robert Riedl Jan 20 '18 at 17:44
  • @code2be: I see. Maybe you type too fast. ;) – Gunnar Hjalmarsson Jan 20 '18 at 17:45
  • @RobertRiedl: Thanks for pointing at that bug report. It may be it. – Gunnar Hjalmarsson Jan 20 '18 at 17:46
  • 1
    @GunnarHjalmarsson : Switching to MATE might be an option, according to one user. – Robert Riedl Jan 20 '18 at 17:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.