0

Recently I have had a problem with my Ubuntu MATE desktop not resuming an ethernet connection after suspend, and occasionally after a cold boot.

What usually fixes it is a 'uncheck' Enable Networking via Network Manager GUI - and them re enabling. If not, I reboot which will fix things.

I'm running lshw -class network:

   *-network
   product: Ethernet Connection (2) I219-V
   vendor: Intel Corporation
   physical id: 1f.6
   bus info: pci@0000:00:1f.6
   logical name: enp0s31f6
   version: 00
   serial: 60:45:cb:7f:9a:0f
   size: 1Gbit/s
   capacity: 1Gbit/s
   width: 32 bits
   clock: 33MHz
   capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k duplex=full firmware=0.8-4 ip=192.168.1.4 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
   resources: irq:122 memory:f7100000-f711ffff

My Ethernet connection is static, IPv6 is off on the Wired connection I use on the machine. I have also turned off Power saving via etc/rc.local file:

!/bin/sh -e
rc.local

This script is executed at the end of each multi-user runlevel. Make sure that the script will exit 0 on success or any other value on error.

In order to enable or disable this script just change the execution bits.

By default this script does nothing.

sleep 10

ethtool --set-eee enp0s31f6 eee off

ethtool -s enp0s31f6 wol d

exit 0

Thanks!

4
  • I have a similar problem; it started about a week ago after an update. After restarting the NetworkManager, NM logs no ifupdown configuration found and state change: unmanaged -> unavailable (reason 'managed') [10 20 2]. Also, I get kernel: [21958.684572] IPv6: ADDRCONF(NETDEV_UP): enp0s31f6: link is not ready. Status LEDs are on; under Windows 10, there are no problems. Any ideas? – dariok Apr 11 '18 at 15:56
  • Dariok, mine actually resolved itself after an update. Not sure exactly what, but I noticed the issue did not reappear after updates. – sprocketoctopus Apr 12 '18 at 22:55
  • thanks for the update. I hope, mine will resolve itself, too. – dariok Apr 19 '18 at 9:13
  • I've just been going through powertop and noticed that „Runtime PM for PCI Device Intel Corporation Ethernet Connection I219-LM“ was set to on (which is reported as „Good“ under „Tunables“) – switching this off immediately brought the ethernet back. I don't remember setting this option, so it is possible that this gets automatically set by some mechanism. I'll keep an eye on it and report back. – dariok Apr 27 '18 at 8:43
0

In powertop, under Tunables, look for "Runtime PM for PCI Device Intel Corporation Ethernet Connection I219-LM"; if it is enabled (Good), toggle it to switch the feature off (reported as Bad). In my case, it immediately brought the ethernet back online.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.