When I realized my wireless wasn't working with ubuntu, I plugged my laptop in to try and figure out the problem online - only to find it doesn't work that way, either. The problem isn't my internet/ cords because I'm using both right now via my wireless desktop.

I'm just getting in to ubuntu and would appreciate any assistance. I've looked around but the only similar questions I could find were about the wireless problem - but I have to deal with the wired problem, first.

Let me know what info I need to give.

~$ lspci -knn | grep -i net -A2
09:00.0 Ethernet controller [0200]: Marvell Technology Group Ltd. 88E8040 PCI-E Fast Ethernet Controller [11ab:4354] (rev 13)
    Subsystem: Dell Device [1028:02aa] 
    Kernel driver in use: sky2 -- 
0c:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
    Subsystem: Dell Wireless 1397 WLAN Mini-Card [1028:000c] 
    Kernel modules: ssb

~$ rfkill list all 
0: dell-wifi: Wireless LAN Soft blocked: yes Hard blocked: yes

The output of lsmod: http://pastebin.com/DqNwKcqZ

  • Any info about the wired/wireless hardware and drivers would be most welcome. In case you know nothing about it, open a terminal window (ctrl+alt+t), then type, or better copy/paste lspci -knn | grep -i net -A2, lsmod and rfkill list all, and let us see its outputs. Since that laptop doesn't have an internet connection, I hope you have a USB stick to save the outputs into a text files. – mikewhatever Jan 30 '12 at 4:40
  • I hope this is an ok way to share the info (If there's some form of formatting the site requires, sorry!) But anyway, yeah, there are the three things you said to look up. Thanks, by the way, @mikewhatever – Jacob Jan 30 '12 at 5:47
  • Ouch! The comment section wasn't the best place for outputs. :~) You can try installing the wireless driver from the installation CD/USB. help.ubuntu.com/community/WifiDocs/Driver/… – mikewhatever Jan 30 '12 at 8:26
  • @Jacob All the useful information is in the question now, can you remove those comments so it's not so confusing? (Click the X next to each one). From now on as you do research just keep editing the question itself, thanks! – Jorge Castro Jan 30 '12 at 14:04
  • Looks like the wireless has a solution here, but we probably need the wired one working first: askubuntu.com/questions/45598/… – Jorge Castro Jan 30 '12 at 14:12

Please try downloading the driver for Linux 2.6 here: http://www.marvell.com/support/downloads/driverDownload.do?driverId=153&action=1 Run install.sh in a terminal, that should fix the problem, it did for the guy in my source. Source: http://ubuntuforums.org/showthread.php?t=1575197 Hope that helps!

| improve this answer | |

The Inspiron 1545 has been certified with Ubuntu since 10.10, with the exact components you describe, so it should work and the hardware should be compatible.


To get the wireless card to work you may need to install additional drivers; for this you'd need the wired network to be working.

One other strange thing is your rfkill output; the hardware should not appear as "hard-blocked", this indicates the wireless switch is in the "disabled" position. Double-check that it's on "enabled". Also, try rmmod dell-laptop, and see if the rfkill status changes. If so, please let me know, as this shouldn't happen on this laptop model.

As for the wired network, that should work out of the box and with no problems. To diagnose this, I suggest you unplug the cable, restart the system, and run tail -f /var/log/syslog on a terminal. Then plug in the cable and look at the log output, to see exactly what happens when you connect this. If you have trouble interpreting the output, you could also pastebin the last lines of the system log and we can look at it to see if we can suggest something else.

| improve this answer | |

I have the wireless portion of this issue solved on my Vostro 1720. It can be found here: Broadcom 4312 wireless issues

Earlier posting:

I just figured this one out again... (I've got the same 1397 WLAN Mini-Card, BCM4312) after a buncha tinkering in the forums and whatnot.

I'm not entirely what SPECIFICALLY fixed it but i do know some of the last things i did were went to http://www.marvell.com/support/downloads/search.do# and snagged Kernel 2.6.x Linux Driver Install Package for Yukon Devices. I followed the directions included in the Readme file as far as installing the tarball.

After I had that installed i reactivated my bcmwl-kernel-source driver and did some good ol sudo rmmod dell-laptop (putting yourself in sudo -s ive found makes root actions easier).

Rebooted this piece and stuff lit all up and wireless is blazing! Now to fix the injection issue.... hopefully! Happy Hunting and I hoped this helped!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.