3

I can mount an SSHFS like this:

sshfs -o idmap=user SSH_HOSTNAME:/ ~/mountpoint

Now it's nicely displayed in Nautilus like a removable device with an eject button. On clicking that button though, I get a permission error:

Unable to unmount “foo”

umount: /home/bytecommander/mountpoint: Permission denied

Same if I directly run umount ~/mountpoint.

I know I can unmount it using fusermount -u ~/mountpoint or I could use sudo umount ~/mountpoint, but I want to get it working in Nautilus (without elevated privileges), which seems to be using umount internally.

How can I achieve this?

PS: I have read somewhere that I should add my user to the fuse group, but there is no such group on my 16.04 system and the mounting works anyway, so I don't think it's needed.

2
  • try running with elevated privileges. – Andrew Shum Jan 19 '18 at 17:26
  • 2
    @AndrewShum That's not really an option, as I don't want to run Nautilus in admin mode just to unmount an SSHFS I own myself. This question is only about getting the unmount from Nautilus working, I know how I can do it from the commandline. – Byte Commander Jan 19 '18 at 17:38
2

Seems to be known bug of GVFS:

Note: my Ubuntu 16.04 has fuse group, I'm member of this group, but Caja has the same problem (it's bug 1763033).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.