1

my keyboard layout seems to randomly have changed. If I didn't have a power-on/BIOS password set up on that machine, it wouldn't be a problem, I could easily find out what layout is being used from the log in screen and switch back to my preferred layout, or use the virtual keyboard.

Not so lucky: I can't boot, get to a terminal window and I'm running out of standard keyboard layout examples.

Device: Lenovo Ideacentre K430

OS: Ubuntu 16.4 (desktop version, not server)

I tried:

  • different wireless and wired mechanical keyboards. Some special characters I need are not recognised (i.e. I hit a special character key and it does not register. All standard characters and numerical pad input seem to register OK though).
  • typing in the password looking at different keyboard layouts online, but many special characters require to use SHIFT in other layouts, which is not a key you can use for BIOS passwords.
  • clearing the password through resetting the jumpers (Edit: no result, regardless of how long I switch from standard position Pin 1&2 to Clear CMOS position Pin 2&3, which I tried for each jumper individually and then for both. Why the motherboard has 2 Clear CMOS jumpers is a mystery to me)
  • removing the CMOS battery (makes no difference, even when removed for over 15 min and whilst the jumpers are on Clear CMOS position)

If anyone has had the same issue and fixed it, I'd really appreciate if they could share their knowledge. I don't have a spare tower to install my hard drive in :(

Thanks in advance LCz

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.