after I installed the language packages from 'unity-tweak-tool' and some simple programs (CopyQ, and similar). lots of problem was occured.

after I closed the unity-tweak-tool. I saw the 'unity-tweak-tool' not showed in the applications list. I tried to reinstall 'unity-tweak-tool'. but it does not install. and get the error E: Unable to correct problems, you have held broken packages.

What I tried

  • I tried to remove it

    sudo apt-get remove unity-tweak-tool 
    sudo apt purge unity-tweak-tool  
    sudo apt autoremove   
    sudo apt update 
    sudo apt -f install

try to install it by aptitude

    sudo aptitude install unity-tweak-tool


    sudo apt-get install --fix-broken
    sudo apt-get autoclean
    sudo apt-get autoremove
    sudo apt-get -f install
  • purge the last installation. (learned from: https://ubuntu-mate.community/t/cant-install-unity-tweak-tool-not-working/7090 )

    sudo apt purge libqgsttools-p1  qml-module-qtquick-privatewidgets  khelpcenter libkf5attica5  libqt5clucene5  libqt5svg5  qml-module-qtquick-window2 libqt5test5  qml-module-qtwebkit  libkf5i18n-data  qml-module-qtquick2 libqt5help5  qml-module-qtquick-controls  libqt5multimedia5  libkf5declarative5 qtwayland5  libqt5dbus5  python3-pyqt5  libqt5sql5-sqlite  qml-module-qtquick-xmllistmodel  qml-module-qtquick-layouts  libqt5widgets5  qml-module-qttest libqt5waylandclient5  qml-module-qtquick-dialogs  kde-style-qtcurve-qt5 qmlscene  libqt5xml5  libqt5quicktest5  libqt5printsupport5  libqt5qml5 libqt5designercomponents5  frameworkintegration  libqt5gui5  libqt5multimedia5-plugins  libqt5quickwidgets5  libqt5x11extras5  libkf5declarative-data libqt5webkit5  libqt5script5  libqt5core5a  libkf5iconthemes-data  libqt5opengl5 libqt5xmlpatterns5  libkf5iconthemes5  qttools5-dev-tools  libqt5network5 libqt5designer5  libqt5positioning5  qtdeclarative5-dev-tools  libkf5kiocore5 libqt5quick5  libqt5sql5  libkf5i18n5  libqt5sql5-mysql  
  • after this, some of application was damaged. (VLC, CopyQ, Glipper , ...)

  • I tried to reinstall them. but noting work. the same error was occured. for example for VLC

    sudo apt install vlc
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    The following packages have unmet dependencies:
    vlc : Depends: vlc-nox (= 2.2.2-5) but 2.2.2-5ubuntu0.16.04.4 is to be installed
     Depends: libgles1-mesa (>= 7.8.1) but it is not going to be installed or
       Recommends: vlc-plugin-notify (= 2.2.2-5) but it is not going to be installed
       Recommends: vlc-plugin-samba (= 2.2.2-5) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
  • After rebooting the system. "Glipper" was auto-strated. but it doesnot showed in the application list.

  • also I tried "synaptic" (resulte for VLC is:)

synaptic VLC Installation Error

Synaptic VLC installation

  • also tried to grep held programs. but nothing showed.

    dpkg --get-selections | grep hold

is there any solution?

2 Answers 2


My problem was fixed. at least for "VLC" and "unity-tweak-tool" programs.

But can not fixed for some programs like "Foxit Reader PDF". since its installation is manually. ("Foxit reader" crashed and closed when highlighting text or doing any comment).

The problem was "I did not use aptitude command correctly."

the detail is:

first run this in terminal (notice: you may need to install "aptitude" package sudo apt-get install aptitude)

sudo aptitude install vlc

after a while it asked:

Keep the following packages at their current version:
    1)     libgles1-mesa [Not Installed]                      
    2)     vlc [Not Installed]                                
    3)     vlc-plugin-notify [Not Installed]                  
    4)     vlc-plugin-samba [Not Installed]                   

    Accept this solution? [Y/n/q/?] n

answered to it by n (No)

then it asked:

Remove the following packages:                                            
    1)      libgl1-mesa-glx:i386                                                    
    2)      libglu1-mesa:i386                                                       
    3)      wine-devel                                                              
    4)      wine-devel-i386:i386                                                    
    5)      wine1.4                                                                 
    6)      wine1.4-amd64                                                           
    7)      winehq-devel                                                            

 Downgrade the following packages:                                         
    8)      libgl1-mesa-glx [17.0.7-0ubuntu0.16.04.2 (now) -> 11.2.0-1ubuntu2 (xenia
    9)      libglapi-mesa [17.0.7-0ubuntu0.16.04.2 (now) -> 11.2.0-1ubuntu2 (xenial)
    10)     libglapi-mesa:i386 [17.0.7-0ubuntu0.16.04.2 (now) -> 11.2.0-1ubuntu2 (xe
    11)     libgles2-mesa [17.0.7-0ubuntu0.16.04.2 (now) -> 11.2.0-1ubuntu2 (xenial)
    12)     libosmesa6 [17.0.7-0ubuntu0.16.04.2 (now) -> 11.2.0-1ubuntu2 (xenial)]  
    13)     libosmesa6:i386 [17.0.7-0ubuntu0.16.04.2 (now) -> 11.2.0-1ubuntu2 (xenia
    14)     libvlccore8 [2.2.2-5ubuntu0.16.04.4 (now) -> 2.2.2-5 (xenial)]          
    15)     vlc-data [2.2.2-5ubuntu0.16.04.4 (now) -> 2.2.2-5 (xenial)]             

    Accept this solution? [Y/n/q/?] y

answer to it by y (yes)

then asked:

The following packages will be DOWNGRADED:
  libgl1-mesa-glx libglapi-mesa libglapi-mesa:i386 libgles2-mesa libosmesa6 
  libosmesa6:i386 libvlccore8 vlc-data 
The following NEW packages will be installed:
  libgles1-mesa{a} libqt5x11extras5{a} vlc vlc-nox{a} vlc-plugin-notify{a} 
The following packages will be REMOVED:
  libgl1-mesa-glx:i386{a} libglu1-mesa:i386{a} wine-devel{a} 
  wine-devel-i386:i386{a} wine1.4{a} wine1.4-amd64{a} winehq-devel{a} 
0 packages upgraded, 6 newly installed, 8 downgraded, 7 to remove and 42     not upgraded.
Need to get 6,395 kB/12.8 MB of archives. After unpacking 168 MB will be freed.
Do you want to continue? [Y/n/?] y

answer y again.

after this, problem was fixed and the VLC was installed correctly.

I hope, This be helpful for others, too.

Thanks for you attention


I had a similar case. I have resolved it the following way.

I have noted all the "Depends" packages and typed apt-get install to install them. It gave me further error with further "Depends" packages. I've noted them also and again typed apt-get install to install them, and so on, until I've reached the final package. Then I typed apt-get remove to remove all the "Depends" packages I have noted before. After that I run apt-get autoremove. Then I was able to install the package I needed without the errror.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .